AB ASD compatibility

Acronis Backup and Acronis Snap Deploy can be installed on one machine provided you use the following versions:

  • Acronis Backup 12.5 Build 11010 and later
  • Acronis Snap Deploy 5 Build 1780 or later

Order of installation:

First, install Acronis Snap Deploy 5

Second, install Acronis Backup 12.5