Try reinstalling or updating your VMware tools to fix the issue
Symptoms
- You are using one of the Acronis Backup products on an ESX Host to back up virtual machines;
- The backup of one or several of the virtual machines fails with an error message similar to one of the following:
Awaiting task has failed (Cannot create a quiesced snapshot because the create snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine)
Creating a quiesced snapshot failed
Creating a quiesced snapshot failed because the create snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine
An error occurred while quiescing the virtual machine. See the virtual machine's event log for details.
VMware failed to create a quiesced snapshot of the selected virtual machine. To back up the machine, power off the machine before the process or uninstall the Volume Shadow Copy Services Support feature of VMware Tools from the VM.
Awaiting task 'CreateSnapshot' has failed. Reason: Cannot create a quiesced snapshot because the create snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine..
Protocol error from VMX
Cause
Please see the solution section of this article for specific causes and resolution.
Solution
1.1 VM snapshot should work correctly
Acronis software uses snapshots executed by the hypervisor while taking the virtual machine backup. It is necessary that these snapshots work correctly. Create a virtual machine snapshot to check the consistency :
- Open the vSphere connection to the ESX host.
- Right click on the machine > take snapshot > check the "Quiesce guest file system"
- Uncheck the "Snapshot the virtual machine's memory" and click OK.
If taking quiesced snapshot fails, investigate the issue with the virtual machine (contact VMware support if needed)
In most cases, reinstalling/updating VMware tools and rebooting the virtual machine will resolve the issue with quiesced snapshot. Please see the following articles:
- VMware Knowledge Base Article 1009073
- VMware Knowledge Base Article 5962168
- VMware Knowledge Base Article 1007696
- VMware Knowledge Base Article 1007346
If quiesced snapshot is created successfully but backup with Acronis still fails with the same error message, contact Acronis Customer Central with a reference to this article
1.2 Verify VSS status
If you backup a virtual machine with transactional applications installed (SQL, Exchange evt.), then:
- VMware Tools should be installed inside that guest OS.
- VSS service should not be disabled inside the guest OS.
In case the guest OS event logs contain errors or warnings for VSS operations during creation of the snapshot, troubleshoot the VSS issues inside the guest OS.
If a virtual machine snapshot fails due to incorrect guest file system quiescing (snapshot without option Quiesce quest file system is successful), for virtual machines with no transcational applications installed you can workaround the issue by uninstalling the VMware Tools for the guest OS (see More information below) or by disabling Volume Shadow Copy (VSS) for Virtual Machines backup option (for Acronis Backup Cloud or Acronis Backup 12 and above).
Keep in mind the VMware ESX(i) virtualization platform limitations: VMware vSphere does not support snapshots of fault tolerant virtual machines, independent disks, and Raw Device Mapping (RDM) disks in physical compatibility mode. To overcome these limitations install an agent into the guest OS.
1.3 If the error message is:
Creating a quiesced snapshot failed because the create snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine
Then see the following articles for a solution:
- VMware Knowledge Base Article 1006114
- VMware Knowledge Base Article 1019848
If ESX(i) version is 6.0, install this patch.
The error may be caused by pre-backup command failure. A pre-backup command (pre-freeze script located in /usr/sbin/pre-freeze-script on a Linux machine or in a specific directory on a Windows machine) is a user-supplied script that should be executed before backup. Usually, these scripts are used to quiesce an application that does not have its own VSS provider (in Windows) to ensure a consistent state before backup. When such a script exits with a non-zero return code, this indicates that the script failed to perform its quiescing task and quiesced snapshot operation has to be cancelled.
See also the following solutions:
- Recreate VM’s snapshot configuration as described in Creating snapshots fails and performing a backup with VCB causes a virtual machine to shut down;
- If VM freezes during snapshot creation, see A virtual machine can freeze under load when you take quiesced snapshots or use custom quiescing scripts;
- If VM runs a database, try giving it more processors/RAM. Allow VM to use more of the host/cluster resources.
More information
You can also try disabling the VSS component of VMware Tools to solve the issue, but only if the backed up VM does not run a database:
- Uninstall the Volume Shadow Copy Services Support feature of VMware Tools from the virtual machine:
- Select the virtual machine in question on ESX server and go to Inventory -> Virtual Machine -> Install/Upgrade VMware Tools:
- This will launch the installation of VMware Tools on the virtual machine:
- Choose Modify:
- Uncheck the Volume Shadow Copy Services Support:
- Complete the modification:
- Reboot the virtual machine;
- Create a backup of this machine which should succeed this time.