59045: Acronis Software: Installation fails with "MainEngineThread is returning 1603" or "MainEngineThread is returning 1618"

Last update: 21-03-2023

Symptoms

You install an Acronis product in a Windows operating system. Installation fails with these messages in MSI log:

MainEngineThread is returning 1603 MSI

or

MainEngineThread is returning 1618 MSI

Example log:
[12:43:00:786]: MainEngineThread is returning 1603 MSI (s) (5C:6C)
[12:43:00:801]: User policy value 'DisableRollback' is 0 MSI (s) (5C:6C)
[12:43:00:801]: Machine policy value 'DisableRollback' is 0 MSI (s) (5C:6C)
[12:43:00:801]: Incrementing counter to disable shutdown. Counter after increment: 0 MSI (s) (5C:6C)
[12:43:00:801]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 MSI (s) (5C:6C)
[12:43:00:801]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 MSI (s) (5C:6C)
[12:43:00:801]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1 MSI (c) (C4:9C)
[12:43:00:801]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1 MSI (c) (C4:9C)
[12:43:00:801]: MainEngineThread is returning 1603

Cause

Another installation is in progress, or a reboot is required after a previous installation.

Solution

  1. Reboot your machine.
  2. Start Task Manager and make sure no msiexec.exe process is running; msiexec is the process of Windows installer. If a msiexec.exe process is present in the Task Manager, an installation is running. To end the process select it and click End task.
  3. Start installing Acronis software.
  4. If the installation fails, follow recommendations from this Microsoft Knowledge Base article.

Collect information

If the problem persists, collect MSI log, Process Monitor log during installation, and System information (in Acronis True Image, in Acronis Backup 12.5 and Acronis Backup 12, in Acronis Backup (Advanced) 11.7) and contact Acronis Support.

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