65204: Acronis Cyber Protect Cloud, Acronis Cyber Backup: Impossible to recover files to the original VM in case of agentless backup

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Last update: 24-08-2021

Symptoms

You create an agentless backup of VMware or Hyper-V virtual machine. 

When you try to recover files from a virtual machine backup to original location, only custom location is available in the recovery wizard:

Cause

Recovery of files from agentless VM backup cannot be made into original location inside the guest OS of the backed up VM, since the agent that performs the recovery by default (Agent for VMware/Agent for Hyper-V) cannot access the files inside the guest OS. 

In order to recover files to the original location, Agent must be installed inside the guest OS and backup must be created using that Agent. 

Files cannot be recovered to the original location if the backup was created by agentless method, even if Agent is installed in guest OS and recovery is done using that Agent.

Solution

There are 2 possible solutions in this case:

1) Recover files to a custom location first, e.g. network share, and then move them to the VM manually.

2) Install an Agent inside the VM to which you want to recover files. Then perform the recovery in the following way:

  • Go to Backups -> Locations (Acronis Cyber Backup 12.5) or Backup Storage -> Locations (in Acronis Cyber Protect Cloud) and select the location where VM backups are stored
  • In Machine to browse from select the VM to which you want to recover files;
  • Select the necessary backup and perform file recovery (see Recovering files by using the web interface)

More information

Acronis plans to add a possibility to directly recover files to original VM in one of the future versions of the product.

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