63996: Acronis Cyber Protect Cloud, Acronis Cyber Backup: backup fails with 'Common I/O error'

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Last update: 26-01-2022

Symptoms

A Linux machine backup fails with this error message:

Message: Failed to create volume snapshot.
------------------------
Error code: 5832705
Fields: {"$module":"disk_bundle_lxa64_15300","device":"/dev/md1"}
Message: Common I/O error.

You see these errors in /var/log/messages/
Jan  6 23:22:11 kernel: heartbeat_timer_func(swapper/0,0): Deadlock detected.dev=900001, cnt=6, state=4. Unfreezing...
Jan  6 23:22:11 kernel: find_deadlocked(snapapid,7404): dev=900001 state=1024
Jan  6 23:22:12 kernel: do_resolver(snapapid,7404): Real cleanup started... s=ffff9b7209fbc000(900001)
Jan  6 23:22:12 kernel: find_deadlocked(snapapid,7404): dev=900001 state=256
Jan  6 23:22:12 kernel: find_deadlocked(snapapid,7404): dev=900002 state=2

Cause

Root causes may vary. In most cases such errors are caused by the memory shortage. There are multiple things that affect memory usage during snapshot initialization, most prominently:

  1. Insufficient hardware resources to process the multi-volume snapshot. Taking snapshots of multiple volumes at the same time rather than one by one requires more resources. 
  2. File system errors that trigger sector-by-sector backup also have some effect, the impact may be quite big depending on the system I/O load.

Troubleshooting

1) Disable Multi-volume snapshot in backup plan settings 

2) Run fsck on all file systems to check the disk integrity. Use the badblocks Linux utility.

More information

If the issue persist, please create a system report Acronis Cyber Protect Cloud: Collecting System Report of the affected machine and contact Acronis Support.