61714: Acronis Cyber Backup: backup fails with "VSS writer has timed out" or "The backup has failed because 'VSS Writer' has timed out during snapshot creation."

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    Last update: 02-03-2023

    Symptoms

    Backup fails with:

    VSS writer ... has timed out 

    OR

    The backup has failed because 'VSS Writer' has timed out during snapshot creation.

    The error may involve different writers, see some of possible writers below:

    • Windows error: (0x800423F2) VSS writer 'System Writer' with class ID 'E8132975-6F93-4464-A53E-1050253AE220' has timed out. This may be caused by too intensive I/O on the machine at the backup start time. Try to re-schedule the backup to some different time. To troubleshoot VSS issues, download and run Acronis VSS Doctor available at https://www.acronis.com/en-us/personal/vss-diagnostic-free-tool/
    • Windows error: (0x800423F2) VSS writer 'ASR Writer' with class ID 'BE000CBE-11FE-4426-9C58-531AA6355FC4' has timed out. This may be caused by too intensive I/O on the machine at the backup start time. Try to re-schedule the backup to some different time. To troubleshoot VSS issues, download and run Acronis VSS Doctor available at https://www.acronis.com/en-us/personal/vss-diagnostic-free-tool/
    • Windows error: (0x800423F2) VSS writer 'Microsoft Hyper-V VSS Writer' with class ID '66841CD4-6DED-4F4B-8F17-FD23F8DDC3DE' has timed out. This may be caused by too intensive I/O on the machine at the backup start time. Try to re-schedule the backup to some different time. To troubleshoot VSS issues, download and run Acronis VSS Doctor available at https://www.acronis.com/en-us/personal/vss-diagnostic-free-tool/ 

    Cause

    The issue is caused by too intensive workload on the machine at the backup start time.

    A VSS writer is application-specific software that acts to ensure that application data is ready for shadow copy creation. Windows OS includes a set of VSS writers and VSS-aware applications install own VSS writers to the machine. If the workload on the machine is high at the backup time, a VSS writer might not respond in the expected timeframe, that is, reach a timeout. A backup made under these conditions might not be restorable, that is why Acronis software cancels this backup and shows this error message.

    Timeout issue of VSS Writers appears when Acronis Agent is waiting for snapshot creation. It is caused by default timeout value for the VSS writers (60 seconds). Since opening and flushing volumes takes significant time, after 60 seconds writers fail and snapshot is aborted, especially if disk load is high.

    Prerequisite

    If you have Windows 8.1, Windows RT 8.1, Windows Server 2012 R2, Windows 8, Windows RT, Windows Server 2012, Windows 7 Service Pack 1 (SP1), or Windows Server 2008 R2 SP1 operating system, make sure that Windows hotfix is installed: Backup task fails with a time-out error in Windows 

    Solution

    As the first troubleshooting step, reschedule the backup to a different time when disk load is lower.

    If you are backing up Hyper-V virtual machines and the Hyper-V host, we recommend scheduling these backups to different times so that backups of multiple virtual machines are not running in parallel.

    To determine what time is better for proper handling of VSS snapshot creation requests, we suggest to use the following scheme:

    • Enable Task failure handling option in the affected backup plan and set the interval between attempts to 40-50 minutes and number of attempts 20
    • Start backup. It will be running in nonstop mode until snapshot creation is successful
    • Note the time when snapshot is created successfully and schedule backup to this time to avoid further snapshot timeout issues.

    You can also use the Perfmon utility to check the current I/O load on disks and find the right time for snapshot operations.

    If the issue persists, please consider the following options to troubleshoot the issue:

    1) Acronis Cyber Backup 12.5, Acronis Cyber Protect 15: create backups with a bootable media. Backups of a shutdown system are application-consistent by default. See this article for details. 

    (!) Creating backups from bootable media is not available in Acronis Cyber Protect Cloud.

    2) Move the system partition via backup-restore to SSD or hardware RAID 0 / 5 / 6 / 10 (ideally based on SSD drives) to increase IOpS (Input/Output Operations Per Second) of the system - this might eliminate a root cause of VSS Writers' timeouts.

    You can find instructions for recovery with bootable media in product documentation:

    3) Consult the software vendor of the affected writer or Microsoft for available troubleshooting. If this specific VSS writer cannot be fixed (for example, the version of the OS is too old) and you know the software isn't actually used on the affected machine, consider uninstalling the software or stopping its service, which uses this VSS writer. Do this only if you are sure these actions will not affect the machine's functioning.

    4) If previous steps do not resolve the issue or are not applicable for some reason, create a snapshot using Diskshadow tool to check the functionality of the VSS service components and contact Microsoft support for assistance if any errors are detected. Snapshot creation with Diskshadow should be tested close to the time when you usually create backups with Acronis Software.

    Please note that NTbackup or "vssadmin create shadow" command is not a valid way to check application-consistent snapshot. Snapshots should be checked with Diskshadow because Diskshadow exposes the functionality of Microsoft Software Shadow Copy Provider which can be in a nutshell described as VSS Writers’ API for third parties.

    If any writer fails with an error or creating a snapshot with Diskshadow does not end with "Number of shadow copies listed: x", you need to troubleshoot this writer and make sure it is functioning correctly before using VSS backup in Acronis Software. 

    Collect information

    If suggested steps did not resolve the issue, collect the following information and contact Acronis Support for further troubleshooting:

    1) Acronis VSS Doctor output,

    2) Collect VSS trace while reproducing the issue: see How to collect VSS trace

    3) System information - see article https://kb.acronis.com/acroinfo

    More information

    To troubleshoot VSS issues, download and run Acronis VSS Doctor available at https://www.acronis.com/personal/vss-diagnostic-free-tool/

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