60817: Acronis Cyber Protect Cloud, Acronis Cyber Backup: transaction logs are not truncated after a backup

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Last update: 03-09-2020

Symptoms

You are backing up a machine with Exchange Server. You notice that transaction logs are not truncated after a backup.

Cause

There are two ways to back up the Exchange Server data: you can either back up only the Exchange databases with a dedicated backup plan or you can back up the volumes where Exchange data reside (application-aware backup).

After a successful database backup, transaction logs are truncated.

Logs truncation after an application-aware backup depends on the agent that is used for backup:

  • If you are backing up a physical or virtual machine where Agent for Windows is installed and activate application-aware backup option, transaction logs are truncated only if the VSS full backup option is enabled. This option is disabled by default.
  • If you are backing up virtual machines using Virtual Appliance or Agent for VMware(Windows) and activate application-aware backup option, transaction logs are truncated automatically. 

Solution

Enable VSS full backup:

  1. In Cyber Protection console, locate the protection plan and click the ellipsis (...) icon to change settings.
  2. Navigate to Volume Shadow Copy Service (VSS) and select Enable VSS full backup.
  3. Save changes.

More information

If Windows Event logs show Application events 2026 and 4088 from MSExchangeRepl at the end of the backup, check if there are dismounted databases on the server. Delete or mount these databases.

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