Diagnose and repair WMI
This article applies to:
- Acronis Disk Director 11 Home
Symptoms
- You launch Acronis Disk Director 11 Home;
- The connection attempt fails with the following error message:
An invalid index has been specified.
Cause
Acronis Disk Director 11 Home could not get the information about network interfaces on the machine by means of the WMI.
One of the symptoms of that is the absence of the information about NICs in Windows System Information File:
- Start -> Run -> msinfo32 -> System Summary -> Components -> Network -> Adapter
Acronis Disk Director needs this information for proper functioning.
There can be several causes for the absence of the information about NICs in Windows System Information File:
- The machine has corrupted WMI repository;
- There is Broadcom Advanced Control Suite (BACS) or Broadcom ASF Management Applications installed on the machine, which adds its own set of classes to the WMI and may fence off the standard Windows queries.
Solution
- Diagnose and troubleshoot WMI issues on the machine with the Acronis Agent. See:
- Microsoft Download Center: WMI Diagnosis Utility;
- Microsoft MSDN Library: WMI Troubleshooting
In the last resort, you may refer to the following web page describing the process of rebuilding WMI repository:
- If the machine has Broadcom Advanced Control Suite (BACS) or Broadcom ASF Management Applications installed, try uninstalling it, reboot the machine and see if it resolves the issue.
If uninstalling BACS does not resolve the issue, try to delete the following classes using the WMI tester dialog box:
- BRCM_3rdPartyNetworkAdapter
- BRCM_NetworkAdapter
- BRCM_VirtualNetworkAdapter
More information
Feel free to contact Acronis Support referencing this article if you have further questions or need assistance.