事象
- 64ビットのコンピュータに、Acronis 管理サーバーがインストールされています。
- 32ビットアーキテクチャのデバイスを追加しようとすると、以下のエラーが表示され、インストールに失敗します:
「インストールプロセスが失敗しました。{"結果":"失敗", "コード":"24510491", "説明":"サーバーからインストールファイル'resource.xml'をダウンロードできませんでした。"」
原因
管理サーバーには、32ビットのリモートインストールのファイルが含まれていません。
Acronis 開発チームは、32ビットアーキテクチャのリモートデバイスを扱う際の製品の動作を改善するように努めています。
ソリューション
- 32ビットのインストーラーをダウンロードします:
- account.acronis.com を使用する場合: 自分のアカウントにログインし、製品の一覧の中から Acronis Cyber Protect 15 を探します。それから、[ダウンロードする] をクリックし、Windows 32ビットのフルインストーラーをダウンロードします。Acronis Cyber Protect サブスクリプションの場合は、[Acronis Cyber Backup のダウンロード] -> [他のダウンロード オプション] をクリックしてから、Windows 32ビットのフルインストーラーをダウンロードします。
- バックアップコンソールを使用する場合: バックアップコンソールの右上隅にあるアカウントのアイコンをクリックし、[ダウンロードする] を選択します。そこから、 オフライン インストーラ for Windows(32ビット)をダウンロードします。
- Acronis 管理サーバーで、C:\Program Files\Acronis\RemoteInstallationFiles\installation_files\<ビルド番号>(たとえば、C:\Program Files\Acronis\RemoteInstallationFiles\installation_files\15.0.25729)に移動します。その中に、x64 というフォルダがあります。
- ビルド番号のフォルダの中で(すなわち、x64 フォルダの隣で)、x86 というフォルダを作成します:
- インストール用のパッケージを抽出するために、Windows 32ビットのフルインストーラーを実行し、[無人インストールの.mstおよび.msiを作成] をクリックします。32ビットのインストーラーから .msi ファイル(管理サーバー、リモートインストール用のコンポーネント、エージェント for Windows)を抽出し、それらのファイルを前のステップで作成した x86 フォルダに置きます。
- Acronis Service Manager サービスを再起動します。そのために、「サービス」ウィンドウを開いて([スタート] -> 検索 -> services.msc と入力 -> Enter キーを押す)、そこで Acronis Service Manager Service を見つけて、[再起動] をクリックします。
- リモートインストールを実行します。
追加情報
Acronis Cyber Backup 12.5 を使用する場合は、Acronis Cyber Backup 12.5: 64ビットの管理サーバーから32ビットのエージェントをリモートインストールする方法 をご参照ください。