事象
以下のエラーが表示され、操作(バックアップ、復元、クリーンアップ)に失敗します:
「Windows エラー: (0x8007051F) 現在、ログオン要求を処理できるログオン サーバーはありません。」
原因
使用するネットワークにおいて、動作している Active Director ドメインコントローラーがあります。このドメインコントローラーはユーザーログインの要求を処理するはずです。しかし、エラーが発生するコンピュータの Windows はこのドメインコントローラーを見つけらず、ログインさせてくれません。考えられる理由は以下の通りです:
- このドメインコントローラーは使用するネットワークにおいて有効になっていません。
- 対象のコンピュータまたはバックアップ先(例えば、NAS)に、間違った DNS IP アドレスが割り当てられています。正常の状態では、同じネットワークのドメインコントローラーの IP と一致しているはずです。
- DNS サーバーは有効な IPv4 を持っていません(つまり、IPv4 127.0.0.1 または IPv6 ::1 が使用されています)。
- その他の DNS 関連の問題。
トラブルシューティング
- 対象のコンピュータがドメインコントローラーが動作しているネットワークに接続されていることを確認してください。
- ドメインコントローラーが有効な状態にあり、正常に動作していることを確認してください。また、ドメインコントローラー上で Netlogon サービスが実行されていることもチェックしてください。
- DNS レコードのキャッシュをクリアしてください。そのために、コマンドプロンプトを開き([スタート] -> 検索 -> cmd と入力)、以下のコマンドを実行します:
ipconfig /flushdns - ネットワーク接続のプロパティで DNS 設定をチェックしてください:
Win+R を押して、ncpa.cpl と入力して、Enter キーを押します。そうすると、[ネットワーク接続] のウィンドウが開きます。使用するインターネットまたは有効なネットワーク接続を右クリックし、[プロパティ] を選択します。
ネットワークアダプターのプロパティのウィンドウで、TCP/IPv4 という項目をクリックし、[プロパティ] ボタンをクリックします。これで DNS 設定を含むウィンドウが開きます。