68365: Acronis Cyber Protect: VMware VDDK 7.0 と一緒に Microsoft Visual C++ 2017 再頒布可能パッケージがインストールされていない場合、「指定されたモジュールが見つかりません」エラーが表示され、仮想コンピュータをバックアップすることまたはバックアップから仮想コンピュータを起動することに失敗します

次の言語でも参照できます:

use Google Translate

次の製品に該当します: 

Operating Systems: 

Last update: 24-03-2021

この記事は以下の製品に適用されます: 

  • Acronis Cyber Cloud C20.12
  • Acronis Cyber Protect 15 アップデート 1

事象

  1. Windows コンピュータにエージェント for VMware(Windows)をインストールします。
  2. vSphere 6.5+ 環境(vCenter または ESXi ホスト)に接続するために、このエージェントを設定します。
  3. VMware vSphere 仮想コンピュータのバックアップを実行しようとしています。
  4. 以下のエラーが表示され、バックアップに失敗します:

2020-11-24T14:48:13:908+03:00 5152 E00000001: エラー 0x1: ダイナミック ライブラリを読み込むことができません。
| トレースレベル: エラー
| 行: 0x384a6390dfd2e5db
| ファイル: e:\ab\core\common\win\shared_library_win.cpp:44
| 関数: `anonymous-namespace'::SharedLibraryWin::Load
| トークン: C:\Program Files\Common Files\Acronis\VirtualWare\VixDiskLib\7.0.1\bin\vim-types.dll
| $モジュール: esx_srv_vsa64_20000
|
| エラー 0xfff0: 指定されたモジュールが見つかりません。
| 行: 0xbd28fdbd64edb8f8
| ファイル: e:\ab\core\common\error.cpp:314
| 関数: Common::Error::AddWindowsError
| コード: 0x8007007e
| $モジュール: esx_srv_vsa64_20000

あるいは

  1. 仮想コンピュータのバックアップをベリファイするために、ディスクレベルのバックアップからその仮想コンピュータを起動しようとしています。
  2. 以下のエラーが表示され、仮想コンピュータの作成に失敗します:
    「Windows エラー: (0x8007007E) 指定されたモジュールが見つかりません。」

原因

VMware VDDK 7.0 の正常動作に必要な Microsoft Visual C++ 2017 再頒布可能パッケージが見つかりません。

ソリューション

Windows Server 2012 または Windows Server 2012 R2 の場合:

Windows での汎用の C ランタイムの更新プログラム をダウンロードし、エージェント for VMware(Windows)がインストールされているサーバーにインストールしてください。

Windows 10 または Windows Server 2016 の場合:

最新のサポートされる Visual C++ のダウンロード から Microsoft Visual C++ 2017 再頒布可能パッケージをダウンロードし、エージェント for VMware(Windows)がインストールされているサーバーにインストールしてください。

追加情報

Acronis 開発チームは、弊社ソフトウェアの将来のバージョンにおいて、エージェント for VMware(Windows)に Microsoft Visual C++ 2017 再頒布可能パッケージを導入することに取り組んでいます。

Acronis エージェント for VMware(Windows)は、VMware ESXi 6.5+ ホストで作業を行うために VMware VDDK 7.0 を使用しています。
VMware VDDK 7.0 は Windows Server 2021 またはそれ以降のバージョンをサポートしています(VMware VDDK 7.0 のリリースノート をご参照ください)。従って、より古いバージョンの Windows にエージェント for VMware(Windows)をインストールすると、このエージェントを使って VMware ESXi 6.5+ ホストに関わる作業はできなくなります。

タグ: