事象
エージェントの登録中に、このエラーが表示されます:
「ホストに接続できません。」
aakore ログでは、以下のエラーが表示されます:
"msg":"tcp bind error: listen tcp 127.0.0.1:9999: bind: address already in use" (日本語訳: アドレスは既に使用中です)
あるいは、
バックアップ アクティビティを実行する際にエラーが表示されます:
「127.0.0.1 ポート 9999 に接続できませんでした: 接続は拒否されました。」
原因
バージョン 9.0 から、ローカル ポート 9999 が着信接続に対して開いている必要があります。このポートは、エージェントと管理用コンポーネントの間の通信のために使われます。
このエラーは、ポート 9999 がすでに他のソフトウェアに使用されていることを意味します(ポート 9999 は Oracle HTTP サーバーにおいて2つのデフォルトの SOAP サーバー ポートの1つになっているため、そのソフトウェアは Oracle HTTP サーバーの可能性が高い)。
以下の手順に従って、このポートを使用するソフトウェアを調べることができます:
Windows の場合:
- 次のコマンドを実行します:
netstat -ano | findstr 9999
これで、9999 でリッスンしているプロセスの PID(プロセス ID)を確認できます。 - それから、次のコマンドを実行します:
tasklist /svc /fi "pid eq <PID>"
上記の <PID> は、ステップ1で確認したプロセスの PID に変えてください。
Linux の場合:
- 次のコマンドを実行します:
netstat -ant | grep 9999
これで、9999 でリッスンしているプロセスの PID(プロセス ID)を確認できます。 - 次のコマンドを実行します:
ps -p <PID> -o comm=
上記の <PID> は、ステップ1で確認したプロセスの PID に変えてください。
ソリューション
Acronis Cyber Protect Cloud 21.01(ビルド 26226)およびそれ以降のバージョンでは、Acronis Agent Core Service(aakore)というサービスはデフォルトでダイナミックポートを使用します(ビルド 26226 またはそれ以降のバージョンをクリーンインストールした場合のみです)。
より古いバージョンの場合、あるいはビルド 26226 が前のビルドの上にインストールされている場合は、Acronis 構成でポート 9999 を変更できます:
1. 対象のコンピュータで以下のパスに移動します:
- Windows の場合: C:\ProgramData\Acronis\Agent\etc\
- Linux の場合: /opt/acronis/etc/
2. メモ帳など使って、aakore.yaml を開きます。
3. 以下の行でポート 9999 を、現在使用されていないポートに変更します:
http: 127.0.0.1:9999
4. aakore サービスを再起動します。