事象
以下のエラーが表示され、アクティビティ(バックアップ、復元、クリーンアップなど)に失敗します:
「ホスト名を解決できませんでした。」
原因
このストレージのホスト名を IP アドレスに解決できないため、ストレージにアクセスできません。ホスト名は解決されない場合と、間違って解決される場合があります。
ソリューション
バックアップ先が Acronis クラウドストレージの場合は、この問題のトラブルシューティングを行うために、接続確認ツール (Connection Verification Tool) を使用してください。
バックアップ先が Acronis クラウドストレージではない場合は、対象のサーバーの DNS 設定をチェックしてください。
この問題のトラブルシューティングとして、エージェントのコンピュータで手動でホスト名で検索してみてください。まずは、コマンドプロンプトを開きます([スタート] -> [ファイル名を指定して実行] -> cmd と入力 -> Enter キーを押します)。コマンドプロンプトで以下のコマンドを実行します:
nslookup <検索するホスト名>
例えば: nslookup mybackupserver.com
コマンドに成功した場合、このホストの IP アドレスが出力されます。
エラーが出力された場合は、エージェントのコンピュータで DNS の構成をチェックしましょう:
- コマンドプロンプトでこのコマンドを実行します: ipconfig /all
- その出力の中で「DNS Servers」を探します:
- 何のサーバーも表示されていない場合、あるいは、表示された DNS サーバーが間違っている場合、使用するコンピュータで DHCP が使われているかどうかチェックします:
- Win+R を押して、ncpa.cpl と入力し、Enter キーを押します。そうすると、[ネットワーク接続] のウィンドウが開きます。
- 使用するインターネットまたは有効なネットワーク接続に該当する項目をダブルクリックし、[詳細] ボタンをクリックします。
- [ネットワーク接続の詳細] のウィンドウで、DHCP が有効かどうか確認します:
- DHCP が有効ではない場合、ネットワーク接続のプロパティで指定されている DNS サーバーをチェックし、正しく指定する必要があります。使用するインターネットまたは有効なネットワーク接続に該当する項目を右クリックし、[プロパティ] を選択します。
開いたプロパティ ウィンドウで、「TCP/IPv4」アイテムをクリックし、[プロパティ] ボタンを押します。そうすると、DNS 設定のセクションを含むウィンドウが開きます。[次の DNS サーバーのアドレスを使う] を選択し、使用する DNS サーバーの IP アドレスを入力します。 - DHCP が有効になっている場合は、その DHCP が正しく設定されていて、DNS アドレスを提供できる状態にあることを確認する必要があります。ご自分の方のすべての設定は確実に間違っていない場合、ネットワーク管理者またはインターネット サービス プロバイダにお問い合わせしてください。
- DNS サーバーが一覧に載っている場合は、その DNS サーバーの設定をチェックします。必要に応じて、ネットワーク管理者またはインターネット サービス プロバイダにお問い合わせし、手伝ってもらってください。
ホスト名が間違った IP に解決される場合、以下の手順に従ってください:
- エージェントのコンピュータ上の С:\Windows\System32\drivers\etc\hosts というファイルの内容をチェックし、そこに必要なホストが間違った IP でリストアップされていないか確認します。
- そこにホストが表示されていない場合は、DNS のキャッシュが破損していて正しくない情報を表示している可能性があります。DNS のキャッシュを削除してみてください。そのために、コマンドプロンプトでこのコマンドを実行します: ipconfig /flushdns
- それでも問題が解決しない場合は、ネットワーク管理者またはインターネット サービス プロバイダにお問い合わせください。