63045: Acronis Backup:「アカウントに、インスタンスにアクセスするための十分な権限がありません」というエラーメッセージが表示され、新しくインストールされたSQL上でアプリケーション認識型バックアップに失敗する場合

次の言語でも参照できます:

use Google Translate

次の製品に該当します: 

事象

SQLインスタンスのアプリケーション認識型バックアップを持っています。

しばらくしてから、自分のSQLサーバーに他のSQLインスタンスを追加します。

バックアップが完了しますが、警告が表示され、2つ目のインスタンスはバックアップされていません。

2019-03-26T13:20:05:728+03:00 2236 W02140000: service_process(2976): Failed to save the metadata for group 'mssql://INSTANCETWO/DB_ONE'. Reason: 'エラー 0x571102: インスタンス 'INSTANCETWO' の SQL Server データベース 'DB_ONE' をバックアップできません。'
| 行: 0xec865955c73bb297
| ファイル: e:\301\enterprise\applications\mssql\aavb\addon\src\aavb_progress_control.cpp:62
| 関数: MsSql::AavbProgressControl::OnDatabaseError
| $モジュール: aavb_mssql_backuper_vsa64_12420
|
| エラー 0x570133:
アカウント '' に、インスタンス 'INSTANCETWO(第2のインスタンス)' にアクセスするための十分な権限がありません。アカウントがインスタンスをバックアップまたは復元できるようになるには、そのアカウントが Microsoft SQL Server sysadmin の役割を持つ必要があります。
| 行: 0xa590150b0bc6beec
| ファイル: e:\301\enterprise\applications\mssql\common\src\online_mssql_server_information.cpp:1213
| 関数: `anonymous-namespace'::OnlineInformationBuilder::CollectMetaWithOdbc
| $モジュール: aavb_mssql_backuper_vsa64_12420'.

原因

MS SQLの認証情報はインスタンスごとに保存されます。新しいインスタンスに自動的に適用されることはありません。

ソリューション

問題を解決するために、以下の方法のどちらかを使用してください:

1. 手動で認証情報を指定します:

  1. [デバイス] -> [Microsoft SQL] に移動します。
  2. 必要なデバイスのデバイス名をクリックします:
  3. 必要なインスタンスのインスタンス名をクリックします:
  4. 認証情報を求められたとき、sysadmin の役割を持つユーザーの認証情報を入力します(ドメインユーザーの場合は、ドメイン\ユーザー という形で入力します):

2. すべての認証情報をリセットするために、カスタムなスクリプトを使用します(KB 61551 をご参照ください)。

You are reporting a typo in the following text:
Simply click the "Send typo report" button to complete the report. You can also include a comment.
CAPTCHA
This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.
10 + 7 =
Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.