62509: Acronis Backup 12.5: Hyper-V 2019 上で、エージェント for Hyper-V のライセンスが時々取り消されます

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Last update: 01-04-2019

事象

  1. Acronis Backup エージェント for Hyper-V がインストールされている Hyper-V 2019 環境を使用しています。
  2. エージェント for Hyper-V に割り当てられたライセンスが時々取り消され、以下のようなエラーでバックアップに失敗します:

    「'pcBackup' 機能は使用できません。適切なライセンスを使用してください。」

  3. [設定] -> [ライセンス] でライセンスを再割り当てしても、数日後にライセンスがまた取り消され、それ以降のバックアップが同じエラーで失敗します。一般的に問題が再現するのは、コンピュータの再起動の後です。

 

 

C:\ProgramData\Acronis\BackupAndRecovery\MMS\mms.0.log にある mms ログをチェックすると、以下のような警告が表示されます:

| エラー 0x1403f4: WMI 'ExecQuery' がクエリ '%ls' に失敗しました。
| 行情報: 0xc523d9a02d03d56e
| ファイル: d:\1164\core\winex\wmi_acc.cpp:323
| 関数: Windows::WMIClass::Select
| クエリ: SELECT * FROM Win32_OptionalFeature WHERE InstallState=1 and Name='Microsoft-Hyper-V'
| $モジュール: hv_srv_vsa64_12422
|
| エラー 0xfff0: 致命的なエラー
| 行情報: 0xbd28fdbd64edb8fb
| ファイル: d:\1164\core\common\error.cpp:317
| 関数: Common::Error::AddHResult
| コード: 0x8000ffff
| $モジュール: hv_srv_vsa64_12422

原因

この製品の既知の問題です。
問題の原因は、WMI の失敗です。それにより、Hyper-V ホストが再起動したとき、Hyper-V のインスタンスの列挙結果に間違いが出てきます。結果として、対象のインスタンスが MMS データベースから削除され、それに割り当てられたライセンスが取り消されます。

ソリューション

この問題は、アップデート4(ビルド12730)で修正されました。最新ビルドにアップデートしてください。

アップデートせずにこの問題を回避したい場合は、このようなエラーが発生したとき、手動でエージェント for Hyper-V にライセンスを再割り当てしてください。そのために、Web コンソールの [設定] -> [ライセンス] セクションを使ってください。 

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