この記事の説明に従って、スクリプトを使用してください。
事象
- Parallels Desktop 仮想コンピュータを含む Mac OS X をバックアップしました。
- このバックアップから仮想コンピュータのファイルを復元しました。
- 復元されたコンピュータは起動しません。
この記事の説明に従って、スクリプトを使用してください。
原因
製品の現在の制限です。
ソリューション
以下のように、復元されたコンピュータのスナップショットの一覧に Acronis スナップショットが含まれている場合は、この仮想コンピュータを起動可能にするためにこのスナップショットに戻してください:
あるいは、recreate_pd_hdd.script を実行することで問題を解決することもできます:
- Acronis True Image 2017 およびそれ以降のバージョンでは、スクリプトは製品に同梱されています。Acronis True Image 2017 がインストールされているコンピュータの /Applications/Acronis True Image.app/Contents/MacOS/recreate_pd_hdd.sh にあります。
Acronis True Image 2016 または 2015の場合、まずは recreate_pd_hdd.zip スクリプトをダウンロード し、解凍する必要があります。 - スクリプトを実行します:
[path_to_script] [path_to_pvm_folder_with_restored_vm_files]
[path_to_script] は、スクリプトの保存先であるフォルダへのパスに変えてください;
[path_to_restored_vm_files] は、仮想コンピュータの復元先である .pvm フォルダへのパスに変えてください。
例:
bash "/Applications/Acronis True Image.app/Contents/MacOS/recreate_pd_hdd.sh" "/Users/John/Downloads/My Windows Virtual Machine.pvm"
追加情報
「マシンがハードドライブへ接続できません」のようなエラー メッセージが表示される場合、この仮想コンピュータを再起動する必要があります。再起動するには、まず、[仮想マシン] をダブルクリックし、[ストップ] をクリックします。それから、[スタート] をクリックします。