インストールを行っているユーザーに、指定したレジストリキーのアクセス許可を付与してください。
本記事の対象製品:
- Acronis True Image 2015
事象
1. Acronis True Image 2015をインストールします。
2. 以下のメッセージが表示され、インストールに失敗します。
Error 1402. Could not open key: <RegistryKeyPath>. Verify that you have sufficient access to that key, or contact your support personnel.
or
Error 1406: Could not write value <Value> to key <RegistryKeyPath>.
原因
インストールを行っているユーザは、エラーメッセージに指定されたレジストリキーのアクセス許可を持っていません。
ソリューション
1. エラーメッセージで、トラブルに関わるレジストリキーの名前を確認します。
2. Windowsレジストリエディタを開きます(「スタート」→「ファイル名を指定して実行」→【regedit】)。
3.エラーメッセージに指定されたキーに移動します。原則として、HKEY_LOCAL_MACHINEのフォルダーに入っています。
4. キーフォルダーに右クリックし、「アクセス許可」を選びます。
5. 「アクセス許可」のダイアログボックスで、「追加」をクリックします。
6. 「グループ名またはユーザー名」のダイアログボックスで、現在ログインしているユーザー名を選びます。「名前の確認」を押し、正しいかどうか確認します。それから、「OK」をクリックします。また、「すべてのユーザー」というオプションも使用できます。
7. 「フルコントロール」の「許可」チェックボックスをオンにして、「詳細設定」を押します。
8. 「子オブジェクトのアクセス許可すべてを、このオブジェクトからの継承可能なアクセス許可で置き換える」のチェックボックスをオンにし、「適用」をクリックします。それから、「OK」を押します。
9. インストールを再実行します。
追加情報
インストールの再実行の時、またエラーが表示される場合、他のレジストリキーに同じトラブルが起きた可能性があります。その場合、エラーメッセージに指定されたレジストリキーを選んで、上記の手順を繰り返してください。
ご不明な点については、Acronis カスタマーセンターへお問い合わせください。