42708: Acronis Backup (Advanced) for VMware: MFT、RunList、Blockビットマップもしくはインデックスが破損していると、バックアップがセクタ単位で取得される

次の言語でも参照できます:

Translate to:

    MFT、RunList、Blockビットマップもしくはインデックスが破損していると、バックアップがセクタ単位で取得されます。

    “ShadowCopyOptimization Writer”を無効にして問題を回避してください。

    この資料は以下の製品に該当します:

    • Acronis Backup for VMware (Acronis vmProtect)
    • Acronis Backup Advanced for VMware (Acronis Backup & Recovery)

    症状

    1. Windows Server 2008 R2、もしくはWindows SBS2011を仮想ゲストシステムとしてバックアップを作成します。
    2. バックアップタスクを実行します。
    3. バックアップ完了後、ログに「バックアップがセクタ単位に切り替わった」とのメッセージが出力されます。 セクタ単位でのバックアップは、デフォルトのバックアップよりも所要時間が長くなります。.   

      ログには以下のようなメッセージが出力されます:

      --------------------
      Error code: 46
      Module: 7
      LineInfo: a5695862aaf8e75e
      Fields: PartitionId : 219
      Message: Forced sector-by-sector mode.
      --------------------
      Error code: 28
      Module: 7
      LineInfo: 89d94b01b483dcca
      Fields:
      Message: Run list is corrupted.
      --------------------

      OR

      --------------------
      Error code: 46
      Module: 7
      LineInfo: a5695862aaf8e75e
      Fields: PartitionId : 227
      Message: Forced sector-by-sector mode.
      --------------------
      Error code: 22
      Module: 7
      LineInfo: 89d94b01b483dcdb
      Fields:
      Message: Block bitmap is corrupted.
      --------------------

      OR

      --------------------
      Error code: 46
      Module: 7
      LineInfo: a5695862aaf8e75e
      Fields: PartitionId : 997
      Message: Forced sector-by-sector mode.
      --------------------
      Error code: 37
      Module: 7
      LineInfo: 89d94b01b483de5a
      Fields:
      Message: Index is corrupted.
      --------------------


      OR

      --------------------
      Error code: 46
      Module: 7
      LineInfo: a5695862aaf8e75e
      Fields: PartitionId : 845
      Message: Forced sector-by-sector mode.
      --------------------
      Error code: 24
      Module: 7
      LineInfo: ef8b1618a4c0dd9c
      Fields:
      Message: MFT bitmap is corrupted.
      --------------------

    原因

    各エラーの解決策については、[解決策]のセクションを参照してください。

    解決策

    次のソリューション ステップは、以下のすべての問題に該当します。何か他のソリューションを試す前に、このステップを実行しておくことを推奨します:

    • chkdskを使用して、ゲストOS内に含まれるすべてのファイルシステムをチェックします。詳細については、ソリューション1(「ランリストが破損しています」)をご参照ください。
      • (!) SystemReserved や RECOVERY などのファイルシステムが隠されている場合もあります。このようなパーティションは、chkdskでチェック可能にするためにドライブ文字を割り当てる必要があります。
    • ゲストOSにVMWare ToolsまたはHyper-V 統合サービスを再インストールし、システムを再起動します。

    上記のステップを実行しても問題が解決しなかった場合、以下のソリューションに進んでください。

    Run list is corrupted (ランリストが破損しています)

    原因:

    バックアップしたVM内のファイルシステムの整合性が原因で、
    Acronis製品からファイルの読み取りができず、セクタ単位でバックアップが開始されたことが考えられます。

    解決策:

    Windowsに組み込まれているユーティリティでファイルシステムチェックを行ってください。仮想マシン上のすべての論理ボリュームでCHKDSKを実行してください:

    • コマンドプロンプトを開きます (スタート -> 実行 -> cmd);
    • 次のコマンドを入力します: chkdsk DISK: /r
      ( DISKにはチェックを行うパーティションのドライブ文字を入力します) 
    • (!)  C: ドライブのチェックを行った場合、マシンの再起動が必要となる場合があります。 すぐに再起動することができない場合は、 /r を除いたパラメタ―を使用して、チェックディスクを実行してください。 チェックディスクを行った結果、問題が見つからなかった場合は、以下のセクションを参照してください。

    Block bitmap is corrupted (ブロック ビットマップが破損しています)

    原因:

    このメッセージは、Acronis vmProtect がブロックサイズの特性により、仮想マシン上の仮想ディスクのブロック構造を認識できない場合に出力されます。

    解決策:

    仮想マシンをシャットダウンし、vSphereクライアントから仮想ディスクのサイズ拡張します (10MBなど。拡張する値は問いません)。ディスクのサイズを増やすことにより、仮想ディスクの構造を再構築し、ブロックサイズに関連する問題を解決します。 問題が解決しない場合は、次の解決策を行ってください。

    Index is corrupted and MFT bitmap is corrupted

    (インデックス/MFT ビットマップが破損しています)

    原因:

    バックアップ時、仮想マシンに高い負荷がかかっていた場合、
    上記のメッセージが出力されることがあります。

    NTFSのジャーナルに記録されているデータがボリュームに
    書き出されていないため、ファイルシステムが破損していると認識され、Acronis製品がNTFSのジャーナルを正常に読み取ることができず、ディスクにデータを書き出すことを要求します。

    このような場合、バックアップは強制的にセクタ単位で実行されます。

    同様の事象はAcronis vmProtect 7でも発生しますが、セクタ単位で
    バックアップが実行された、とのメッセージは非表示になっており、デバックモードでのみ確認することができます。

    また、この事象は毎回発生するものではなく、スナップショットが作成される際の、VMのシステム状態によって事象が発生します。

    この問題は、次期以降のAcronis vmProtectとAcronis Backup & Recovery Virtual Editionにて修正予定です。

    回避策:

    Windows 2008 R2にデフォルトでインストールされている、"Shadow Copy Optimization Writer" (http://msdn.microsoft.com/en-us/library/bb968827%28VS.85%29.aspx#shadow_copy_optimization_writer)というVSSライタが原因です。

    このVSSライタがスナップショットの修正を行うことが原因で事象が発生するため、VMware Toolsから、このVSSライタを無効にします。

    特定のVSSライタを無効にする方法については、以下のVMwareの資料を
    ご参照ください:

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd...

    もしくは、バックアップを行ったWindows 2008R2/SBS2011VMで、以下のファイルを作成します:


    vmbackup.conf %ALLUSERSPROFILE%\Application Data\VMware\VMware Tools\


    ノートパット上でファイルを開き、以下の文字列を追加します:

    Shadow Copy Optimization Writer

    VMware Tools Serviceを再起動し、再度VMのバックアップを実行してください。

    上記に示されている手順は、問題が修正されるまでの回避策です。
    メッセージを無視するか、上記に説明されている手順を使用し、
    問題を回避してください。

    メッセージを無視する場合は、このようなメッセージが出力された際に取得したバックアップから、ファイル/フォルダ単位での復元ができない可能性があることをご了承ください。
    (ランダムに発生する事象であるため、すべてのケースにおいて
    ファイル/フォルダの復元ができなくなってしまうことはありません)

    エラーが発生している場合も、詳細復元を行う際にVM全体の復元や、バックアップからVMを起動することが可能です(「バックアップからVMを起動」オプションを使用することにより)。

     Acronis vmProtect 8: Run VM from Backupも併せてご参照ください。

    追加情報

    Acronis vmProtect 9をご参照ください。

     

    You are reporting a typo in the following text:
    Simply click the "Send typo report" button to complete the report. You can also include a comment.
    CAPTCHA
    This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.
    2 + 1 =
    Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.