回避策として、Acronis VSS の代わりに Microsoft VSS を使用します。
事象
- Windowsサーバ上に Active Directory ドメインサービス(SBSもしくはドメインコントローラ)と NTDS VSS ライタが存在しています。
(!) システム上のライタのリストを確認するには、[スタート] -> [ファイル名を指定して実行] -> cmd を入力し、開いたコマンドラインで vssadmin list writers というコマンドを実行してください。
2. このサーバーのディスクバックアップを作成します。[ボリュームシャドウコピーサービス(VSS)を使用する] が選択されており、スナップショットプロバイダは [ソフトウェア - Acronis VSS プロバイダ] と設定されています。
3. 下記のようなスナップショット関連のエラーが出力され、バックアップが失敗します:
「ボリュームスナップショットの作成に失敗しました。」
4. Windows のアプリケーションイベントログには、下記のようなエラーが出力されます:
「ログ名: アプリケーション
ソース: ESENT
イベント ID: 455
タスクのカテゴリー: ログ/復元
レベル: エラー
説明:
lsass (616) ログ ファイル C:\Device\snapman\Windows\ntds\edb.log を開いているときに、エラー -1023 (0xfffffc01) が発生しました。」
5. エラーログには、下記のようなエラーが記載されています:
「不明な Win32 エラー
イベントコード: 0x000101F6+0x00070021+0x0010C442+0x0010C469+0x0000FFF0+0x800423F0」
あるいは
「不明な Win32 エラー
イベントコード: 0x0135003D+0x01490003+0x00010424+0x00070021+0x0010C442+0x0010C469+0x0000FFF0+0x800423F0」
原因
Acronis VSSプロバイダの制限により、 VSS プロバイダと NTDS ライタの通信に起因して発生している事象です。
VSS のサポートのために Acronis VSS プロバイダが使用されている場合、最後に作成されるスナップショットは Acronis SnapAPI ドライバによって作成されます。NTDS ライタはスナップショットのパスを必要としますが、SnapAPI スナップショットと Acronis VSS プロバイダの機能では正常にパスの取得ができません。
ソリューション
Acronis VSS Doctor ツール(無料) を使って、VSS 関連の問題をトラブルシューティングしてみてください。このツールを使っても問題が解決しなかった場合は、以下の手順に従ってください。
回避策として、Acronis VSS の代わりに、Microsoft VSS プロバイダを使用してください。
ボリュームシャドウコピーサービスのオプションで、「ボリュームシャドウコピーサービス(VSS)を使用する」が選択されていることを確認してください。
スナップショットプロバイダのメニューで、[ソフトウェア - システムプロバイダ] を選択します。
Acronis Cyber Backup: Acronis VSS の代わりに Microsoft VSS を使用する方法 もご参照ください。
(!)Microsoft SharePoint Foundation 2010 Service Pack 1(SP1)のインストール終了後、Windows Small Business Server 2011 で Microsoft VSS プロバイダを使用したバックアップが正常に動作しない場合があります。それは別の問題です。
追加情報
(!)この回避策はシステム上に Active Directory ドメインサービスと、NTDS VSS ライタが存在する場合のみ適用できます。他のオペレーティングシステムで同様の事象が発生する場合は、この記事の適用範囲外のため、調査が必要となります。Acronis カスタマーセンターにお問い合わせください(お問い合わせの際、この記事を参照したことをお伝えください)。