67199: Acronis Cyber Protect Cloud: Updating Agent to build 23140 fails on 32-bit systems

use Google Translate

Operating Systems: 

Last update: ven, 2020-09-18 18:38

Symptoms

After updating Acronis Agent to 23140 on Windows XP or another 32-bit system, the device goes offline.

Installation of this build fails on the registration step with these errors in aakore log:

{"time":"2020-08-27T05:58:12.130+02:00","level":"error","msg":"ping external network: asn1: structure error: integer too large"}

Manual registration fails with:

"text" : "{\"domain\":\"AGENT_CORE\",\"code\":\"COMMUNICATION_ERROR\",\"debug\":{\"msg\":\"ensure registration: create registration: setup regstate: datacenter discovery: Get [https://eu-cloud.acronis.com:443/api/1/accounts?login=victo??|https://eu-cloud.acronis.com/api/1/accounts?login=<login>: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)\"}}

Cause

Limitations on cryptography data related to certificates that can be passed within 32-bit systems.

Solution

Remove the “D-TRUST Qualified Root CA 1 2007:PN” certificate from Trusted Root Certification Store.

  1. Open the Certificates snap-in: in Search, type certmgr.msc and press Enter.
  2. Navigate to Trusted Root Certification Authorities -> Certificates.
  3. Locate "D-TRUST Qualified Root CA 1 2007:PN". Right-click and select Delete. You need administrative priviliges to see this option in the list.