63024: Acronis True Image: unable to select a disk for new backup, already configured backups fail, if volsnap is missing from UpperFilters in the system registry

Last update: mar, 2020-11-24 12:22

Symptom 1

Entire PC or Disks and partitions backup fails with error "The operation was terminated because no Volsnap driver was found."

Symptom 2

Entire PC backup interrupts with message "Source is not selected. The operation has been terminated".

Symptom 3

After interruptions and retries, illustrated above, Entire PC backup transitions to the "failed state" and a red cross is displayed. The error text says "Source is not selected. The operation has been terminated".

Symptom 4

If you try creating a new "Disk and partitions" backup, "OK" button is grayed out and a message appears: "Unable to back up a locked volume encrypted with BitLocker. Unlock the volume or turn off BitLocker, and then try again.", even though the selected disk volume is in "unlocked" state (see Compatibility with Bitlocker).

Cause

Acronis True Image uses Microsoft Volume Shadow Copy service (VSS) to access disks for backup. If there is any problem with VSS, backup may not work properly.

The above described symptoms can occur when "volsnap" entry is missing from UpperFilters under the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{71a27cdd-812a-11d0-bec7-08002be2092f} in the system registry.

volsnap is the Volume Shadow Copy driver and is required to not only be up and running, but also present in the aforementioned registry key, for Microsoft Volume Shadow Copy service to function correctly.

volsnap could have been erroneously removed from the registry key by a third-party software, e.g. antivirus or a system optimization software.

Solution

Product behavior was improved in Acronis True Image 2021 Update 2 (Build 34340), please update to the latest build.

If the issue reproduces with build 34340 or later, add the missing volsnap entry in the system registry resolve the issue:

  1. Enable "Complete memory dump" option in Control Panel - System - Advanced - Startup and recovery - Settings, as per https://kb.acronis.com/content/17639. It will help Acronis investigate the issue, if a BSOD occurs, and you contact Acronis Customer Central.
  2. Make a backup of the folder, where the system registry is stored C:\Windows\System32\Config as a precaution measure, by using Acronis Bootable Media. Alternatively, you can create a backup of the whole system disk with the same bootable media.
  3. Back in Windows, add volsnap in the system registry:
    1. Open Windows Start menu, type regedit, press Enter on keyboard
    2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{71a27cdd-812a-11d0-bec7-08002be2092f}
    3. Double-click on UpperFilters in the registry editor.
    4. Add volsnap on a new line before fltsrv, so that all entries in the box "Value data" are written one per line
      If you don't see fltsrv in UpperFilters, please add it, like shown on the picture below.

    5. Click OK
  4. Reboot the computer
  5. If a BSOD occurs and you are in contact with Acronis Customer Central, capture the memory dump C:\Windows\MEMORY.DMP by creating a file-level backup from bootable media and upload .tib to the FTP account, that you were provided by Acronis. Restore from the earlier created backup to fix the Windows boot issue.

Further investigation

You may be asked by Acronis Customer Central representative to collect diagnostic information to help Acronis investigate the issue.

  1. Screenshot of the registry, confirming that volsnap is missing
  2. System report: https://kb.acronis.com/content/58820
  3. VSS Doctor output: https://www.acronis.com/en-us/personal/vss-diagnostic-free-tool/
  4. The .tib file, with C:\Windows\MEMORY.DMP inside, captured at step 5 above.

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