Symptoms
- After performing V2V restore (VMWare backed-up machine to Scale HC3), you are facing the following issues:
1. The VM runs normally, but cumulative updates failing with the error "0x8007054f"
2. Not possible to replace the VirtIO Red Hat SCSI controller driver with a new version.
Cause
Issue in the product.
This issue will be resolved in one of the upcoming updates.
In the meantime, please follow the workaround below
Workaround
Log in to the affected machine and conduct the following steps:
1. Copy the files viostor.inf and vioser.inf to C:\Windows\INF from:
C:\Windows\System32\DriverStore\FileRepository\viostor.inf_amd64_4b7257e3cb809845
C:\Windows\System32\DriverStore\FileRepository\vioser.inf_amd64_4b1c86b19cf7dd94
2. Run "regedit" and add two registry entries:
- [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\viostor] "Owners"=hex(7):76,00,69,00,6f,00,73,00,74,00,6f,00,72,00,2e,00,69,00,6e,00,66,\ 00,00,00,00,00 ; * Which is actually read as viostor.inf
- [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VirtioSerial] "Owners"=hex(7):76,00,69,00,6f,00,73,00,65,00,72,00,2e,00,69,00,6e,00,66,00,00,\ 00,00,00 ; * Which is actually read as vioser.inf
3. Reboot the Operating System.
4. Allow the administrator user, under which the tests are performed, to modify the content of the registry in the path HKEY_LOCAL_MACHINE\SYSTEM\DriverDatabase\DeviceIds:
- Run "regedit" and browse to the mentioned path: HKEY_LOCAL_MACHINE\SYSTEM\DriverDatabase\DeviceIds
- Right-click over DeviceIds key and click "Advanced"
- Change the "Owner" to the user which is performing this test
- Set "Access" as "Full Control"
5. Apply the attached registry patch (mods.reg):
- [HKEY_LOCAL_MACHINE\SYSTEM\DriverDatabase\DeviceIds\{4d36e97d-e325-11ce-bfc1-08002be10318}] "vioser.inf"=- "vioser.inf"=hex(0):
- [HKEY_LOCAL_MACHINE\SYSTEM\DriverDatabase\DeviceIds\{4d36e97b-e325-11ce-bfc1-08002be10318}] "viostor.inf"=- "viostor.inf"=hex(0):
6. Revoke the given permission in step 4
- Run "regedit" and browse to the mentioned path:HKEY_LOCAL_MACHINE\SYSTEM\DriverDatabase\DeviceIds
- Set up the ownership to "Administrators".
7. Restart the system
8. Re-try the updates that were failing
More information
For further assistance, please contact Acronis Support with a reference to this article.