71519: Installation of Acronis True Image OEM System Builder fails with "Sysprep was not able to validate your Windows installation"

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Last update: 07-12-2022

Symptoms

On Windows 11, you are installing Acronis True Image OEM System Builder using the below steps:
 

  1. On the Windows 11 machine, place AcronisTrueImageSB installation file, OEM_install and answer_file_x64 files into the same folder.
  2. In the Command Prompt, start installation of Acronis True Image System Builder.
  3. On the Sysprep step, navigate to folder C:\Windows\System32\Sysprep and run the command: sysprep /generalize /oobe /unattend:<path_to_answer_file>

The installation fails with "Sysprep was not able to validate your Windows installation".

Cause

A Microsoft issue, only Windows 11 is affected. 

Solution

To workaround the issue, please follow the below instructions:
 

  1. Open the folder C:\Windows\system32\sysprep\Actionfiles
  2. Add write permissions to the file Generalize.xml 

  3. Remove the following XML node from the file Generalize.xml and save the file 

<imaging exclude="">
    <assemblyIdentity name="Microsoft-Windows-AppX-Sysprep" version="10.0.19041.1566" publicKeyToken="31bf3856ad364e35" processorArchitecture="amd64" versionScope="NonSxS"/>
    <sysprepOrder order="0x1A00"/>
    <sysprepValidate methodName="SysprepGeneralizeValidate" moduleName="$(runtime.system32)\AppxSysprep.dll"/>
    <sysprepModule methodName="SysprepGeneralize" moduleName="$(runtime.system32)\AppxSysprep.dll"/>
</imaging>

  1. Launch the Sysprep again

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