Grant permissions for the specified registry key to the user running installation.
Symptoms
- You are installing Acronis True Image(any version) in Windows.
- Installation fails with:
Error 1402. Could not open key: <RegistryKeyPath>. Verify that you have sufficient access to that key, or contact your support personnel.
or
Error 1406: Could not write value <Value> to key <RegistryKeyPath>.
Cause
User you are running installation under does not have enough permissions over the registry key specified in the error message.
Solution
- Check the error message and note the registry key which needs to be corrected.
- Open the Windows Registry Editor: Start -> Run -> regedit.exe
- Navigate to the key indicated in the error message (typically located under HKEY_LOCAL_MACHINE).
- Right-click on the key folder and select Permissions.
- In the Permissions dialog box, click Add.
- In the Select Users, Computers, or Groups dialog box, enter the specific username that you are logged in as (click Check Names to be sure), and then click OK. You can also use the Everyone user.
- Select Allow for the Full Control checkbox and click Advanced.
- Select the Replace all child object permissions with inheritable permission from the object option, click Apply and then OK.
- Run the installation again.
More information
If you receive another error, than another registry key may be affected. If this is the case, you need to repeat this procedure for the new registry entry.
Please contact Acronis Support if you need assistance.