40971: Acronis Backup: Backup schlägt fehl mit 'Der Shadow Copy Provider hat einen unerwarteten Fehler beim Versuch, die spezifizierte Aktion durchzuführen'
VSS-Backup schlägt mit 'Der Shadow Copy Provider hat einen unerwarteten Fehler beim Versuch, die spezifizierte Aktion durchzuführen' fehl. Um dieses Problem zu lösen, beheben Sie den entsprechenden VSS Provider Fehler.
Sie aktivieren VSS-Snapshot für Backup und starten ein Partitions- oder Diskbackup;
Backup schlägt mit einer solchen Meldung fehl:
Der Shadow Copy Provider hat einen unerwarteten Fehler beim Versuch, die spezifizierte Aktion durchzuführen.
Die Anforderung wird nicht unterstützt
Nicht gesperrt
Lösung
Prüfen Sie Windows Applikation-Ereignisanzeige.
In der Windows Applikation-Ereignisanzeige sind Ereignisse ID 8193 und ID 12293 aufgelistet.
Protokollname: Applikation Quelle: VSS Datum: Ereignis-ID: 12293 Aufgabenketegorie: Keine Ebene: Fehler Schlüsselwörter:Klassisch Benutzer: Nicht zutreffend Computer: Servername Beschreibung: Volumeschattenkopie-Dienstfehler: Beim Aufrufen von Routine ist ein Fehler aufgetretten.
und
Protokollname: Application Quelle: VSS Datum: Ereignis-ID: 8193 Aufgabenkategorie:Keine Ebene: Fehler Schlüsselwörter:Klassisch Benutzer: Nicht zutreffend Computer: Beschreibung: Volumeschattenkopie-Dienstfehler: Beim Aufrufen von Routine "Cannot find anymore diff area candidates for volume \\?\Volumexxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx\ [0]" ist ein Fehler aufgetretten. hr = 0x8000ffff
Ursache
Nicht genügend Speicher, um Volumenschattenkopie zu erstellen oder Schattenkopie ist für die Volume nicht aktiviert.
Lösung
Um prüfen zu können, ob die Volume genügend Speicher für eine Schattenkopie hat, erstellen Sie eine Schattenkopie mit Windows nativen Mitteln und stellen Sie sicher, dass die Schattenkopie erfolgreich erstellt werden kann. Falls notwendig, verschieben Sie Schattenspeicher zu einer anderen Volume oder machen Sie Platz frei.
Wählen Sie, auf welchem Betriebssystem das Backup ausgeführt wird:: Server OS or Workstation OS.
Navigieren Sie zu Mein Computer -> Klicken Sie mit der rechten Maustaste auf eine interne Volume -> Schattenkopien konfigurieren
Wählen Sie die Volume, die Sie prüfen möchten und klicken Sie auf Schattenkopie erstellen um zu prüfen, ob Speicherplatz für Schattenkopie ausreicht. Falls notwendig, passen Sie Speicherplatz an.
Sie können auch vssadmin utility benutzen, um Schattenkopie zu prüfen, Speicherplatz zu vergrößern oder zu verschieben.
Navigieren Sie zu Start -> Ausführen -> diskmgmt.msc. Überprüfen Sie die Größe von allen Volumen. Falls eine Volume 1024 MB oder kleiner ist, kann es nicht mit VSS gesichert werden, Erklärung dafür finden Sie in diesem Artikel von MSDN. Vergrößern Sie die Volume bis zu 1025 MB oder mehr, oder schließen Sie die Volume aus dem Backup aus.
Navigieren Sie zur Systemsteuerung -> System - >Computerschutz
Wählen Sie die Volume, die Sie prüfen möchten und klicken Sie auf Schattenkopie erstellen um sicherzustellen, dass Speicherplatz für eine Schattenkopie ausreicht. Falls notwendig, stellen Sie die Computerschutz ein und vergrößern Sie Schattenkopiespeicher.
Um prüfen zu können, ob eine Volume genügend Speicherplatz frei hat und eine Schattenkopie zu erstellen, führen Sie die ntbackup Utility aus und sichern Sie einige Daten von der Volume, die Sie prüfen möchten. Starten Sie cmd und geben Sie ntbackup.exe ein.
Falls notwendig, können Sie Speicherplatz für eine Schattenkopie vergrößern, indem Sie zu Systemsteuerung -> System -> Systemwiederherstellung navigieren und Speicherplatz konfigurieren.