Dieser Artikel beschreibt mögliche Ursachen und Lösungen.
Dieser Artikel betrifft:
- Acronis Backup for VMware 9 (Acronis vmProtect 9)
- Acronis vmProtect 8
- Acronis vmProtect 7
Symptome
Exchange-aware Backup schlägt mit folgendem Fehler im Log fehl:
16 Error 1/13/12 5:19:25 PM Failed to prepare for the Microsoft Exchange database validation.
Additional info:
--------------------
Error code: 368
Module: 149
LineInfo: 4db9605401c151e5
Fields:
Message: Failed to prepare for the Microsoft Exchange database validation.
--------------------
Error code: 358
Module: 149
LineInfo: 4db9605401c1509b
Fields:
Message: VSS metadata is missing or corrupt.
--------------------
Error code: 1001
Module: 460
LineInfo: df98e120ab10cc45
Fields:
Message: Failed to parse MsExchange VSS writer metadata.
--------------------
Error code: 1003
Module: 460
LineInfo: df98e120ab10cc2d
Fields:
Message: Expected XML tag not found: WRITER_COMPONENTS
Oder mit folgendem Fehler im log. Siehe Lösung #3 für diesen speziellen Fehler. Beachten Sie die Fett gedruckte Zeile:
Task 'Exchange' failed: 'Failed to create a backup.
Additional info:
--------------------
Error code: 3
Module: 435
LineInfo: 555b5abba09501ab
Fields:
Message: Failed to create a backup.
--------------------
Error code: 32786
Module: 114
LineInfo: 28314c961de7d3ba
Fields:
Message: Vorbereitung auf das Backup fehlgeschlagen.
--------------------
Error code: 353
Module: 149
LineInfo: a71592046cb2c5f3
Fields:
Message: Failed to back up the group.
--------------------
Error code: 2
Module: 218
LineInfo: 338a407ad20e0987
Fields:
Message: Ausführen der Backup- und Recovery-Engine fehlgschlagen.
--------------------
Error code: 367
Module: 149
LineInfo: 63216460909351a3
Fields: command : --check-env
Message: The agent on the guest system has failed to process the request.
--------------------
Error code: 1
Module: 470
LineInfo: dd1e7a681d3fe6a8
Fields: $module : C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\1995738C-A9A9-4B1F-ADBE-5C7E2D8A98EE\exchange_backup_agent.exe
Message: Failed to process command 'CheckEnvironment'.
--------------------
Error code: 25
Module: 470
LineInfo: 43403141c47105d9
Fields:
Message: The VSS components of VMware Tools are corrupted or not installed.
--------------------'.
Ursache
Es gibt mehrere mögliche Ursachen. Bitte gehen Sie durch die Sektion Lösung in diesem Artikel.
Lösung
- Wenn Ihr Microsoft Exchange auf einem Windows 2008 System in einer ESX(i) 4.1 Umgebung läuft, stellen Sie bitte sicher, dass der Parameter disk.EnableUUID in der Exchange VM Konfiguration vorhanden ist. Für detaillierte Instruktionen, folgen Sie bitte dem Artikel in der VMware KB: Enabling Windows 2008 application-consistent quiescing on ESX/ESXi 4.1.
- Exchange-aware Backup ist nicht ohne weitere Einstellungen möglich, wenn Microsoft Exchange auf einem Windows 2003 SBS System installiert ist. Bei einer Standardinstallation schaltet das Setup für Microsoft Windows Small Business Server 2003 den Volume Shadow Copy Service für Microsoft Exchange Server 2003 ab. Um die Daten mit Acronis zu sichern, muss der Volume Shadow Copy Service für Exchange 2003 aktiviert werden: Siehe Microsoft TechNet: Troubleshooting Exchange Server Protection Issues. Für Exchange 2007/2010 Versionen ist der VSS Writer standardmäßig aktiviert, so dass diese Versionen nicht von diesem Problem betroffen sind. Dies Verhalten ist By-Design.
- Diese Lösung gilt für ESX(i)5.0 oder älter. (!) Diese Lösung trifft nur auf die Meldung The VSS components of VMware Tools are corrupted or not installed zu.
Der VMware Snapshot Provider Service wird für die Stilllegung des Gast Dateisystems benötigt. Dieser Dienst ist im Falle eines Windows 2003 Server x64, der als Domain Controller konfiguriert ist, nicht installiert (Der VMware Tools Installer bricht die Installation des VMware Snapshot Provider Service ab). Die Lösung dafür ist, die notwendigen COM Komponenten manuell zu registrieren, wie in der VMware KB beschrieben: Unable to create snapshots on Windows guest operating systems. Um sicherzustellen, dass die Registrierung der VMware Snapshot Provider COM Komponente korrekt registriert wird, benutzen Sie folgendes Kommando für die Registrierung, welches eine Ausgabe in einem Log File erzeugt: "C:\Programme\VMware\VMware Tools\COMREG.EXE" -register "C:\Programme\VMware\VMware Tools\Drivers\vss\VCBSnapshotProvider.dll" "VMware Snapshot Provider" "vmvss" "VMware Snapshot Provider" > C:\register.log 2>&1 . Das Log wird nach einem Erfolg ähnlich aussehen, wie folgt:
Couldn't find application to unregister: VMware Snapshot Provider
Creating new COM+ application (VMware Snapshot Provider)...
Setting application options...
Creating the service...
Registering the DLL...
Securing the application...
Searching for admin group using WMI...
Searching for LocalSystem account using WMI...
Granting new role to LocalSystem user...
Done! - Im Fall einer nicht-interaktiven (stillen) Installation der VMware Tools auf einer VM mit Exchange werden die VSS Module nicht korrekt registriert. Die Lösung in diesem Fall ist, die VMware Tool wiederholt im interaktiven Modus zu installieren. Dazu loggen Sie sich in die VM ein und starten dort die Installation der VMware Tools.
- Im Fall, dass in der VM mit Microsoft Exchange die Benutzerkontensteuerung (UAC) aktiviert ist, stellen Sie sicher, dass Sie den Exchange Backup Agent installiert haben, bevor Sie ein Exchange-aware Backup von dieser Maschine starten (kann aus dem Installationspaket vonAcronis Backup for VMware extrahiert werden).
- Falls keiner der obigen Schritte helfen sollte, ist der häufigste Grund ein fehlerhaftes vss_manifests***.zip Archiv, welches während des Snapshots mit der Stilllegung des Gastdateisystems der MS Exchange VM generiert wird, z.B. es wird kein korrekter VSS manifest Ouptut erzeugt.
Wenn Sie einen Snapshot mit der Stilllegung des Gastdateisystems im vSphere Client von dieser VM mit Exchange erzeugen, muss dort eine Datei vss_manifests***.zip im Datastore der VM erzeugt werden:
Unter normalen Umständen ist die VSS manifests .zip nicht leer, falls jedoch einige Probleme mit den VMware Tools auftreten, wird auch der Output beschädigt, was bedeutet, die VMware Tools müssen neu installiert werden.
- Wenn die Neuinstallation der VMware Tools nicht zum Erfolg führt, sammeln Sie bitte folgende Information, nachdem Sie einen Snapshot mit stillgelegtem Gastdateisystem der VM mit Exchange erzeugt haben:
- Den Output des vssadmin list writers Kommandos aus dem Gast Betriebssystem (Exchange VM), um zu prüfen, dass dort keine Fehler zu sehen sind. Siehe VSS Log Files;
- Windows System Information aus dem Gast System (Exchange VM): Start -> Ausführen -> msinfo32 -> In Datei speichern…
- Windows Event Logs aus dem Gast System (Exchange VM): Start -> Ausführen -> eventvwr.msc. Beide, System- und Anwendungs- Logs werden benötigt.
- Das vss_manifests***.zip Archiv, welches in Schritt 5 weiter oben beschrieben wurde.
Weitere Information
Siehe auch Acronis Backup for VMware 9.