Insert the "export NOSMBFS=1" to /usr/sbin/acronis_mms to fix the issue
This article applies to:
- Acronis Backup & Recovery 10 Advanced Server
- Acronis Backup & Recovery 10 Server for Linux (Standalone)
- Acronis Backup & Recovery 10 Advanced Server - Virtual Edition
Symptoms
- You connect to an Acronis Agent for Linux and try to browse to a backup on SMB share;
- The wizard shows subfolders in the share similar to:
:x2e
:x31
:x32
:x33
:x34 - The share cannot be browsed.
Cause
The SMB client does not have UTF-8 support.
Solution
On the machine where the Acronis Agent for Linux is installed, insert the export NOSMBFS=1 line to /usr/sbin/acronis_mms, and restart Acronis Managed Machine service:
# /etc/init.d/acronis_mms restart
The acronis_mms should look like this:
#!/bin/bash
[ -r /usr/lib/Acronis/system_libs/config ] && . /usr/lib/Acronis/system_libs/config
IFS=""
ulimit -s 2048
export NOSMBFS=1
if [ ! -z "$WRAPPER" ]; then
exec $WRAPPER --library-path /usr/lib/Acronis/system_libs:/usr/lib/Acronis/Common:/usr/lib/Acronis/BackupAndRecovery/Common
/usr/lib/Acronis/BackupAndRecovery/mms $*
else
export LD_LIBRARY_PATH=/usr/lib/Acronis/system_libs:/usr/lib/Acronis/Common:/usr/lib/Acronis/BackupAndRecovery/Common
exec $WRAPPER /usr/lib/Acronis/BackupAndRecovery/mms $*
fi
More information
Modern SMB clients have UTF-8 support.