8536: Acronis Backup & Recovery 10: DCOM Server Errors in Event Log

Last update: 14-04-2011

This has been fixed.

This article applies to:

  • Acronis Backup & Recovery 10 Advanced Server
  • Acronis Backup & Recovery 10 Server for Windows (Standalone)
  • Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition

(!) If you have a Fujitsu Agent installed, see Acronis Backup & Recovery 10: DCOM Local Activation Permission Errors in Event Logs if Fujitsu Agent is Installed.

Symptoms

After installation of Acronis Backup & Recovery 10, in the Event Viewer -> System log there are error messages similar to the following ones:

Access denied attempting to launch a DCOM Server using DefaultLaunchPermssion.
Server: {2C5DFFB3-472F-11CE-A030-00AA00339A98} User: Acronis Agent
User/"Servername"

Access denied attempting to launch a DCOM Server. The server is:
{2C5DFFB3-472F-11CE-A030-00AA00339A98} The user is Acronis Agent User

Cause

The user account under which an application launch is attempted does not have DCOM permissions.

Solution

This has been fixed and the fix is available in the latest build of the product. See Installation of the latest update of an Acronis product.

To work around the issue without downloading the latest build, do the following:

  1. Copy the value from the Event log and search for it in the registry:

    HKEY_CLASSES_ROOT\CLSID\

    An example of the value is 2C5DFFB3-472F-11CE-A030-00AA00339A98;

  2. Once found, copy the AppID and search for it in the registry. This will give you the name of the application that needs to have the permissions.
  3. Grant the permissions as described in Microsoft Knowledge Base Article 899965.

More information

Feel free to contact Acronis Support if you have questions or need assistance.

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