7815: Acronis Virtualization: Backup of Virtual Machine Fails with "Failed to open the virtual machine"

Last update: 20-02-2023

Independent disks cannot be backed up with the virtual appliance when the virtual machine is turned on

Symptoms

 

  1. You are using the Virtual Appliance (Acronis Agent for ESX/ESXi) to back up virtual machines;
  2. One or several of your virtual machines fail to be backed up, when they are turned on, with the following error:

    Failed to open the virtual machine ([STORAGE] MyVm.vmx)
    |Additional info: |--------------------|Error code: 103|Module: 83|LineInfo: a859dd78cc91dcb0|Fields: |
    Message: Failed to open the virtual machine ([STORAGE] MyVm.vmx)
    |--------------------|Error code: 103|Module: 83|LineInfo: a859dd78cc91dc87|Fields: |
    Message: Cannot obtain information on the virtual machine's independent persistent disks because the machine is not powered off at the moment.

  3. If you open the ESX console and look into the properties of the virtual machine, you find that the machine is using a persistent disk:

Cause

There is no possibility to snapshot independent disks when they are turned on. This is an ESX limitation.

Solution

There are three possible workarounds:

  • Do not use independent disks in your virtual machines, and change the existing disks into nonpersistent;
  • Turn off the virtual machines that use persistent disks before you back them up;
  • For Acronis Cyber Backup: Install the Acronis Agent for Windows or Linux into the actual virtual machine, after which the machine will appear under Physical machines.

More information

You may experience a similar issue with mapped raw disks. In this case, the first step to troubleshoot would be to try creating a snapshot in the ESX console and see if it works.

Tags: