7599: Acronis Recovery for Microsoft Exchange or Acronis Recovery for MS SQL Server: Backups on Windows Server 2008 Show "Unable to access operation system directories" Error in the Log

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Operating Systems:

Substitute the ComputerManagement.dll library with a newer one to fix the issue

This article applies to:

Symptoms

  1. Using Acronis Recovery for Microsoft Exchange or Acronis Recovery for MS SQL Server, you run a backup;
  2. The backup job errors out with one of the following error messages in the operation log:

    Unable to access operation system directories

    Unable to access common network parameters. Invalid gateways are specified

  3. Log shows that both backup and validation are successful.

Cause

Issue in the product.

Solution

  • Download and unpack ComputerManagement.dll;
  • On the actual Microsoft Exchange Server or Microsoft SQL Server with the Acronis Agent installed go to Start-Run -> services.msc -> and stop the Acronis Remote Agent service;
  • Then on the same machine go to the following folder:
    • Windows 32-bit: C:\Program Files\Common Files\Acronis\DatabaseBackup\Fomatik\
    • Windows 64-bit: C:\Program Files (x86)\Common Files\Acronis\DatabaseBackup\Fomatik\
  • Rename the existing ComputerManagement.dll file to ComputerManagement.old;
  • Copy the downloaded ComputerManagement.dll to this same folder;
  • Go to Start-Run -> services.msc -> and start the Acronis Remote Agent service.

More information

This has been fixed.

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