This is an issue in the product
This article applies to:
- Acronis Backup & Recovery 10 Advanced Server
- Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
- Acronis Backup & Recovery 10 Advanced Workstation
- Acronis Backup & Recovery 10 Advanced Server - Virtual Edition
Symptoms
- You have Acronis Management Server and Acronis Storage Node of Acronis Backup & Recovery 10 Build 11133 or lower running on the same machine;
- You attempt to update the product to Build 11345, however the installation of the update fails with the following error entries in the MSI log:
(!) For information on how to create an MSI log, please see Creating an MS Installer Log of Acronis Software.
MSI (s) (C4!FC) [17:32:39:335]: Creating MSIHANDLE (5402) of type 790531 for thread 7164
1: AMS, msg: MergeUserPermissionsOnFileObject: Processing 'C:\Documents and Settings\All Users\Application
Data\Acronis\BackupAndRecovery\TapeLocation\9cec6bf0-4ab3-4920-bda6-2b1c9dc05a83\computers\001D21B4-5511-4067-822D-9CABE97F0C0F.F7F34C09-9C59-4EEA-8795-A8E6745F1E25\users\S-1-5-21-3376614687-3223766918-2393868875-1174\'...
MSI (s) (C4!FC) [17:32:39:335]: Closing MSIHANDLE (5402) of type 790531 for thread 7164
MSI (s) (C4!FC) [17:32:39:335]: Creating MSIHANDLE (5403) of type 790531 for thread 7164
1: AMS, msg: MergeUserPermissionsOnFileObject failed: old security descriptor created with error:123
MSI (s) (C4!FC) [17:32:39:335]: Closing MSIHANDLE (5403) of type 790531 for thread 7164
MSI (s) (C4:F8) [17:32:39:344]: Closing MSIHANDLE (5076) of type 790536 for thread 6632
1: MSIGEN:MsiManagementServerServiceInstall: Failed to SetFullAccessOnStorageDir for name: acronistest, domain: acrotest
MSI (s) (C4:E8) [17:32:39:344]: User policy value 'DisableRollback' is 0
MSI (s) (C4:E8) [17:32:39:344]: Machine policy value 'DisableRollback' is 0
Action ended 17:32:39: InstallFinalize. Return value 3.
Cause
This is an issue in the product. Acronis Backup & Recovery 10 cannot modify permissions on folders that have the path longer than 255 characters.
Solution
- Stop the Acronis Management Server and Acronis Storage Node services:
- Hit Start-Run and type in services.msc;
- Right-click on the following services and select Stop:
- Acronis Management Server Service
- Acronis Storage Node Server Service
- Create a temporary C:\Acronis\ folder;
- Temporarily move (CTRL-X) the following folder to C:\Acronis\:
- Windows 2000/2003/XP: \Documents and Settings\All Users\Application Data\Acronis\BackupAndRecovery\TapeLocation\
- Windows Vista/2008, Windows 7: \ProgramData\Acronis BackupAndRecovery\TapeLocation\
- Run the update installation again;
- Once completed, stop the Acronis Management Server and Acronis Storage Node services again;
- Move the TapeLocation folder from C:\Acronis\ back to the original location (replacing all the files):
- Windows 2000/2003/XP: \Documents and Settings\All Users\Application Data\Acronis\BackupAndRecovery\TapeLocation\
- Windows Vista/2008, Windows 7: \ProgramData\Acronis BackupAndRecovery\TapeLocation\