7497: Acronis Backup & Recovery 10 Build 11345: Backup Fails with "Partition Error"

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Operating Systems: 

This has been fixed

This article applies to:

  • Acronis Backup & Recovery 10 Advanced Server Build 11345
  • Acronis Backup & Recovery 10 Server for Windows (Standalone) Build 11345
  • Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition Build 11345
  • Acronis Backup & Recovery 10 Advanced Workstation Build 11345
  • Acronis Backup & Recovery 10 Workstation (Standalone) Build 11345
  • Acronis Backup & Recovery 10 Advanced Server - Virtual Edition Build 11345

Symptoms

  1. Using Acronis Backup & Recovery 10 you are trying to do a volume or disk backup;
  2. In the backup options, you set the following:
    • Multi-volume snapshot -> Enable:

    • Volume Shadow Copy Service -> Create snapshots using VSS:

  3. The backup fails with one of the following error messages in the log:

Partition Error. Some of the selected partitions have the following error: MFT bitmap is corrupted..

Partition Error. Some of the selected partitions have the following error: Run list is corrupted..

Partition Error. Some of the selected partitions have the following error: Invalid file reference..

Cause

This is an issue in the resizer module of the snapshot manager driver.

Solution

This has been fixed and the fix is available in the latest released build of the product. See Installation of the latest update of an Acronis product.

It is strongly recommended to update to the latest build. However, if you would like to have the issue fixed without installing the latest build, proceed as described below:

(!) Do not install SnapAPI Build 512 over Acronis Backup & Recovery 10 Build 11639. You may only install it over Acronis Backup & Recovery 10 Build 11345.

If you have Acronis Backup & Recovery 10 Build 11345 or lower, download, unpack and install SnapAPI Build 512 on all the machines that you back up with the product.

(!) After the installation of SnapAPI Build 512 you will be asked to reboot the machine. You can either reboot the machine, or ignore the message and restart the Acronis Managed Machine Service by doing the following:

  • Hit Start-Run and type in services.msc;
  • Right-click on the Acronis Managed Machine Service and select Restart.

More information

Please note that if the above solution does not help, there might be file system errors on some of the partitions, and we recommend checking your disks for errors:

  • Go to the Command Line (Start-Run -> cmd);
  • Enter the following command:

    chkdsk DISK: /r

    where DISK is the partition letter you need to check. Please note, that checking the C: drive may require you to reboot the machine.

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