Symptoms
- Auto-update of agent finishes with error "Failed to launch installation or update support service on host '..'. Failed to uninstall existing service. The specified service has been marked for deletion."
Cause
Issue is caused by acroinst2 process hanging or still running in the background.
Troubleshooting
- First of all, please collect process snapshot to investigate the issue:
- Open Windows Task Manager
- Open Details tab
- Right click on acroinst2 process
- Select Create dump file
- Contact Acronis Support with the collected log
2. After collecting the process snapshot log, reboot the Machine and restart the update.
3. If rebooting the machine isn't possible, kill acroinst2.exe process from Windows Task Manager and restart the update.
More information
Acronis Development team will improve the error message in one of the nearest releases.