71593: Acronis Cyber Protect 15: Login to Cyber Protect Console fails because Acronis Management Server Service and ZeroMQ Gateway Service are not getting started

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Last update: 09-05-2023

Symptoms

  • You cannot open Cyber Protect Console.
  • Both Acronis Management Server Service and ZeroMQ Gateway Service are not getting started.
  • After checking the zmq and api-gateway logs, the following error messages can be found:

     

Cause

Issue with api-gateway OAuth2 credentials.

Solution

To resolve the issue, account_server.db should be fixed:

  1. Open https://www.sqlite.org/download.html and download "command-line tools for managing SQLite database files" for the system, unpack them
  2. Download and unpack update_allowed_grant_types.zip to the folder where sqlite3.exe is located
  3. Stop Acronis Service Manager Service
  4. Make a backup copy of C:\ProgramData\Acronis\AccountServer\account_server.db (e.g. zip it and copy to another folder)
  5. Open cmd and change the directory to the directory with sqlite3.exe: cd path_to_sqlite3.exe
  6. Run the command: sqlite3 C:\ProgramData\Acronis\AccountServer\account_server.db < update_allowed_grant_types.sql
  7. Start Acronis Service Manager Service again

 

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