71507: Acronis Cyber Infrastructure: Updating Backup storage certificate fails with "mismatched user names" error

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Last update: 01-12-2022

Symptoms

1. Backup storage is provisioned and registered under Acronis Cyber Protect Cloud;

2. On attempt to update Backup storage certificate per KB59997 the following error is being observed:

mismatched user names: have 'X' on the command line, and 'Y' in '/mnt/vstorage/vols/acronis-backup/<path>/.abgw.registration-info'

For example:

Cause

The name of the user for Backup storage certificate update is expected to match the one saved in registration info file on storage - the user initially used for Backup storage registration.

Solution

1. Double-check the value of abc-account parameter in registration info file using the following command:

# grep -RFin abc-account /mnt/vstorage/vols/acronis-backup/certs*

Example output:

[root@abgw-01 ~]# grep -RFin abc-account /mnt/vstorage/vols/acronis-backup/certs*
/mnt/vstorage/vols/acronis-backup/certs.92470a60-4131-410b-acc1-4fe06685424c/.abgw.registration-info:3:abc-account = old_partner_admin_user

Note: in case of multiple registrations there will be several registration info files, check the one related to the required registration in accordance to UID in file path.
More information about registrations via CLI may be found using vstorage-abgw-register list command.

Try to update certificates using the credentials of the Acronis Cyber Protect Cloud user from the output in the certificate update login form.

In case if it is not possible to use the user specified in registration info file (e.g. user is no longer used and it is not possible to restore credentials of that user), proceed with the next step.

2. Prepare another user in Acronis Cyber Protect Cloud eligible for Backup storage registration:

  • user belongs to the same Partner tenant under which Backup storage is registered;
  • user has "Company administrator" role;
  • user has 2FA "Disabled" (marked as service account).

3. Make a backup copy of the registration info file obtained on the step 1:

[root@abgw-01 ~]# cp /mnt/vstorage/vols/acronis-backup/certs.92470a60-4131-410b-acc1-4fe06685424c/.abgw.registration-info /root/registration-info.bkp

4. Replace the value of abc-account parameter in registration info file manually, for example if old username is old_partner_admin_user and new username is my_partner_service_admin_user:

[root@abgw-01 ~]# sed -i 's/old_partner_admin_user/my_partner_service_admin_user/g' /mnt/vstorage/vols/acronis-backup/certs.92470a60-4131-410b-acc1-4fe06685424c/.abgw.registration-info
[root@abgw-01 ~]# grep -RFin abc-account /mnt/vstorage/vols/acronis-backup/certs*
/mnt/vstorage/vols/acronis-backup/certs.92470a60-4131-410b-acc1-4fe06685424c/.abgw.registration-info:3:abc-account = my_partner_service_admin_user

5. Try updating certificates again using credentials of newly specified user.

More information

Contact Acronis support in case if the issue with certificate update will persist.

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