71500: Acronis Cyber Protect: The confirmation window is not displayed on the agent machine when you try to connect to a mac device

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Operating Systems: 

Last update: 16-05-2023

Scenario 1

  1. On a mac device you have applied an Agent plan with Screen Sharing
  2. You have requested to connect to the machine with agent twice by asking for control
  3. On the remote machine with agent, the confirmation window is displayed but the user DOESN'T deny or allow the request
  4. You requested to connect to the machine with agent for the third time
  5. On the remote machine with agent, the confirmation window is not displayed to the user this time

Scenario 2

  1. On a mac device you have applied an Agent plan with Screen Sharing
  2. You have requested to connect to the machine with agent by asking for control
  3. On the remote machine with agent, the confirmation window is displayed but the user DOESN'T deny or allow the request
  4. After some time, the window for reconnection is displayed and the user selects to reconnect
  5. The confirmation window "asking for control/observe" is displayed again and the user denies or allows connections.
  6. The next (third) connection, "asking for control/observe" is not displayed on the agent machine.

Cause

This is a macOS issue that cannot be fixed on our side.

Workaround

Use workload credentials (macOS user credentials) to connect to the mac device. More information can be found in the Product Documentation