71324: Acronis Cyber Protect: Agent installation on a Domain controller fails with the error: "The trust relationship between the primary domain and the trusted domain failed."

Last update: 16-01-2023

Symptoms

  • You are trying to install Acronis cyber protect Agent on a Domain Controller
  • Machine is a Secondary domain controller and a Primary domain controller exists in the environment
  • Installation fails with the error "The trust relationship between the primary domain and the trusted domain failed."

Cause

Connectivity issue with the Domain Controller.

Troubleshooting

  1. On the domain controller, open Windows event viewer: Start -> in Search, type eventvwr.exe and press Enter.
  2. Navigate to Windows Logs -> System. Click Filter Current Log. In Event level, select Error.
  3. Check if the following error is available at the time of the failed operation:
Event[63043]:
  Log Name: System
  Source: NETLOGON
  Date: 2022-08-11T09:19:48.612
  Event ID: 5719
  Task: N/A
  Level: Error
  Opcode: Info
  Keyword: Classic
  User: N/A
  User Name: N/A
  Computer: '...'
  Description: 
This computer was not able to set up a secure session with a domain controller in domain '..' due to the following: 
There are currently no logon servers available to service the logon request. 
This may lead to authentication problems. Make sure that this computer is connected to the network. If the problem persists, please contact your domain administrator.  

ADDITIONAL INFO 
If this computer is a domain controller for the specified domain, it sets up the secure session to the primary domain controller emulator in the specified domain. Otherwise, this computer sets up the secure session to any domain controller in the specified domain.

4. Follow the solution shown to resolve the issue

More information

If the issue persists, follow these Microsoft articles to troubleshoot issues with setting up a secure session with a domain controller:

Microsoft Article 1

Microsoft Article 2

 

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