Symptoms
- You have created a protection plan and enabled Application aware backup of SQL.
- Backup ends with the warning: "The user account that is running Managed Machine Service does not have enough privileges to access instance '...'".
Cause
The user account that is running Acronis Managed Machine Service does not have enough privileges to access the SQL instance
Solution
To be able to back up or recover the SQL instance, the account must have the SQL Server sysadmin role in it:
- Make sure that required rights are assigned to the user account
- Check that the user account is added to SQL Server security logins and that it has the "sysadmin" role for the SQL instance:
More information
If the above steps did not help to resolve the issue, collect following information and contact Acronis Support
- Collect Process Monitor log
- Collect system report