Symptoms
Microsoft 365 Cloud-to-Cloud (C2C) backup or restore jobs are being executed slower than expected and take significant time to complete.
Cause
Cloud-to-Cloud backups are not that dependent on the total size of the backed up data (though this also has its role) but rather on the number of items that are being backed up.
Each separate item creates a separate request to Microsoft and depending on the number, throttling can be enabled on Microsoft side to reduce the load.
This behavior is most commonly observed during the first full backup of a M365 item (mailbox, OneDrive, SharePoint, etc.) since the subsequent backups are incremental and only changed files are being backed up.
In some particular scenarios, however, an incremental backup can be switched to a full one and that might result in throttling.
More information on these scenarios can be found in this article.
The process of recovering M365 data is similar to the backups and also includes API requests thus can trigger throttling.
Solution
The kind of throttling that occurs with backups and recoveries has the status code 429 ("Too many requests") and is enabled by Microsoft - Acronis cannot disable it.
The task can be canceled and restarted but the behavior will most likely reoccur.
If you suspect this and want to confirm the root cause of a slow C2C backup or restore operation, contact Acronis Support with a reference to this KB article.
More information
More information on the throttling types, including status code 429, and what can trigger them can be found in the Microsoft documentation.