70785: Acronis Cyber Protect: Agent inside restored Virtual Machine is automatically disabled

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Last update: 13-12-2022

Symptoms

  • You create backup of a machine which has Acronis Agent for Windows or Linux installed
  • You run this backup as VM (“Instant Restore” feature) and finalize it via Agent for VMware/ Hyper-V
  • When this Virtual Machine is powered on, the Agent for Windows/ Linux does not start automatically within the guest Operating System.

Cause

The Agent inside the guest OS is automatically disabled during the “run as VM” processes in order to avoid potential conflicts.

 

Solution

After finalization, the Virtual Machine can be protected in agentless mode (using the same agent which performed the “Instant Restore” operation). Agentless mode is recommended in most scenarios as it allows to reduce the management overhead.

If you want to re-enable the Agent for Windows/ Linux inside the Virtual Machine:

1. Log into the guest OS of the Virtual Machine and delete the following file:

  • Windows: C:\ProgramData\Acronis\PostRebootResult\run_as_vm
  • Linux: /var/lib/Acronis/PostRebootResult/run_as_vm

2. Start Acronis Managed Machine Service from Windows services management:

  • press “Win” + “R” buttons -> type “services.msc” -> hit “Enter”

 

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