Symptoms
- Agent auto-update or remote update fails with {"Result":"Failed", "Code":"6452534", "Description":"The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance."}
- In bootstrapper logs, you see errors with code 0x80080005
Cause
An issue in the environment: Acronis installation code cannot set up communication with the MSI service to perform the install.
If you receive the error on C22.08 or newer builds (15.0.30161+), it is caused by the known issue in product. Refer to KB70711: Acronis Cyber Protect Cloud: Agent update fails with "Fatal error during installation. Failed to wait for filter driver 'ngscan' to unload. Reboot the operating system, and then retry the installation." for more details
Troubleshooting
You can check these troubleshooting steps to find and fix the issue in the environment:
- Run the Windows Update troubleshooter. More information can be found in this Windows article
- Scan your system for issues by running the following commands:
- Reset Windows Update components. More information can be found in this Windows article
- Take ownership of the System Volume Information directory:
- Use the Registry Editor to create a single value:
- Disable the Windows Update service. Steps can be found in this article
- Upgrade with the Media Creation Tool. More information can be found in this Windows article
- Disable the third-party antivirus software if you have one.