70404: Acronis Cyber Files Cloud: The Unified agent cannot sync down a RO folder from the Cloud

use Google Translate

Last update: 12-04-2022

Symptoms

  • You have updated to the latest version of the Unified agent of Acronis Cyber Files Cloud.
  • The folders on the File server are shared with read-only permissions
  • Download of 'Sync down' read-only share prompts the following sync errors: "File permission error" or "Internal error"

Cause

The agent removes the ability to change permission from the user when "Read only" flag is set. If no other group allows him to change those permission, the agent can't remove the read-only flag to sync down the folder content.

The issue will be fixed in the next update.

Workaround

Give the "Everyone" group permission to edit the permissions of the sync folder:

  1. Open folder properties of the sync folder.
  2. Choose the "Security" tab and open "Advanced" window                                                                               
  3. Select "Replace all child object permission entries with inheritable permission entries from this object" 
  4. Click on Add
  5. The principal name should be "Everyone"                                                                       
  6. Give it permissions to "List folder/ read data", "Write attributes" and "Change permissions".
  7. Click on "OK" to save changes.

 

Tags: