70091: Acronis Cyber Protect Cloud: Agent update fails with "Task timeout expired. The agent that is responsible for processing the task is not accessible"

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Last update: 16-09-2022

Symptoms

Auto-update or remote update fails with the following error:

Task timeout expired. The agent that is responsible for processing the task is not accessible

Cause

Acp-update-controller service cannot connect to the Agent Core service. In such case Acronis Update Controller switches to "emergency update" mode, in this mode update tasks are not handled.

Solution

The issue was fixed in C22.08, but users should perform the following steps to apply the solution:

  1. Stop Acronis Agent Core service (this will also automatically stop Acronis Managed Machine Service);
  2. Stop Acronis Update Controller service
  3. Wait for a few minutes.
  4. Start aakore service (Acronis Agent Core Service)
  5. Start mms service (Acronis Managed Machine Service)
  6. Start Acronis Update Controller service

After that, update controller should be able to communicate with aakore and will work as intended. The machine should be able to automatically update to the latest version available.

These steps should be done only once.

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