69913: Acronis Cyber Protect Cloud: cPanel/WHM Integration plugin may return an empty slice list if multi-machine webcp protection plan is applied

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Last update: 18-11-2022

Symptoms

The plugin for cPanel/WHM returns an empty list of locations in getRecoveryPoints. But when browsing the same archive in the Acronis Backup Console, using the same machine as the agent to browse from, we can see recovery points:

Usually, no errors are shown by the plugin's UI. It just shows an empty list of restore points (backup slices). cPanel just returns: "There are no backups yet."

The protection plan that is used is a multi-machine one, i.e. the same plan is applied to several cPanel hosts, and not only to this one individually.

The backup plan is backing up just fine, without any errors or warnings. The backup plan might have been assigned to the cPanel hosts, and working fine, even for years. All of a sudden it has stopped showing backups.

Typically, multiple/most (but not necessarily all, or at least not all once the issue first starts happening) of the cPanel hosts which share the plan are affected in this way.

Additional symptoms

In the cPanel/WHM plugin's main.log we could see empty locations, like this:

[2021-12-08 10:15:59] [INFO] SrvRequest: {"jsonrpc": "2.0", "method": "getRecoveryPoints", "params": {"user": "root"}, "id": "61afeb2f5bc43"} Socket creds: {'pid': 1583, 'uid': 0, 'gid': 0}
[2021-12-08 10:15:59] [INFO] MmsRequest: {"method": "getRecoveryPoints", "params": {}, "id": 31063, "jsonrpc": "2.0"} /var/lib/Acronis/AgentCommData/mms-comm/in/7<some_UUID>
[2021-12-08 10:16:00] [INFO] MmsResponse: {"id":31063,"jsonrpc":"2.0","result":{"locations":[],"recoveryPoints":[]}} /var/lib/Acronis/AgentCommData/mms-comm/out/<Some_UUID>
[2021-12-08 10:16:00] [INFO] SrvResponse: {"result": {"recoveryPoints": []}, "id": "61afeb2f5bc43", "jsonrpc": "2.0"}

 

In mms.0.log we see entries like these:
2021-12-08T10:15:57:113+11:00 140469251888896 I00000000: Webcp: GetBackupInfo: backup enabled
2021-12-08T10:15:57:122+11:00 140469251888896 I00000000: Webcp: GetBackupInfo: backupStatus is -1, error code is 0, next 1638976254 
2021-12-08T10:16:00:939+11:00 140469251888896 I00000000: Webcp: GetBackupInfo: backup enabled
2021-12-08T10:16:00:948+11:00 140469251888896 I00000000: Webcp: GetBackupInfo: backupStatus is -1, error code is 0, next 1638976254

Re-installing the plugin and/or re-installing the agent does not help.

Cause

An issue in the product.

The issue is caused by the fact that the plan is not applied to a machine, but to the group of machines.

Solution

This issue has been fixed in Acronis Cyber Protect Cloud 22.01 (Agent build 28816).

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