Symptoms
- Agent setup hangs during update due to deadlock in DeviceLock agent.
- Windows System log contains messages from Service Control Manager:
-
A timeout (600000 milliseconds) was reached while waiting for a transaction response from the Device Lock service.
OR
1. Agent installation, uninstallation, or update fails with "Fatal error during installation",
2. In MSI logs (C:\ProgramData\Acronis\InstallationLogs), when searching for "Return value 3" you see "Error 0x8007041d: failed to stop 'Device Lock' service”
Other possible symptoms that can appear if installation did not fail but some components were not updated due to service deadlock:
- Agent is offline after update
- Acronis services are disabled, do not start or terminate unexpectedly
- Backups fail
- MSI log ends with the following message:
Service volume_tracker is installed
Cause
Issue in the product.
Acronis Development team is working on a fix.
Troubleshooting
- Stop the DeviceLock Service and reattempt the installation
- If the installation still hangs with DeviceLock service stopped, uninstall the product using Cleanup Utility, then install the latest build.