Symptoms
1) An Entire machine backup fails with the following error:
ASYNC: Full barrier action job
2) SnapAPI logs contain entries about disks with zero signature:
[20211006-210003-549][SnapAPI][T] Disk 00000057322CA650: Read MBR [20211006-210003-549][SnapAPI][T] NTSignature: 0x0
Cause
In most cases, this issue appears when a special USB stick (such as Technical Security Module or similar tool for encryption and/or access protection) with protected MBR is connected to the machine.
When preparing for a disk backup, Acronis Cyber Protect reads the NT signatures of disks. The protected USB stick has a zero NT signature, and the program attempts to generate a random NT signature and assign it to this disk, so it can be identified, but the operation fails because MBR on this media is write-protected.
Solution
There are two possible workarounds:
- If possible, remove MBR protection from the protected USB stick(or disk) using the manufacturer's tools, and run a backup. After the first backup is successfully created, you can reenable the protection, backups by the same backup plan should work correctly after that.
- Instead of an Entire machine backup, configure a disk/partition backup and select the necessary disks directly. Unplug the protected USB stick while configuring the backup.