Symptoms
- You try to edit or apply an existing protection plan,
- The "Save" button is greyed out, and an alert appears:
Cyber protection functionality is not fully available on X machines. Update the agent on these machines to enable full cyber protection."
Cause
Every Cloud release implements changes and critical fixes in Active Protection functionality. Therefore, existing plans become incompatible with older agent versions.
If you cancel changes, the protection plan will continue working as configured, even for the machines with older versions of the agent.
Product behavior will be changed in future releases to allow better compatibility for older versions of the Agents with new product functions.
Solution
There are two possible workarounds in this case:
- Update Agents on the affected machines
- Remove the affected machines from the protection plan: in this case, it will be possible to save changes. You can create a separate protection plan for these machines until the Agent can be updated.