Symptoms
You have created a custom user on Scale Computing HC3 and specify this user in Acronis Agent for Scale Computing during initial configuration instead of built-in "admin" user.
You perform the backup of Scale Computing HC3 VMs and after some time the Agent for Scale Computing appears to have excessive 26 snapshots attached to it (left from the backed up VMs).
The backup starts to fail with the following error:
The maximum number of virtual disks (26) attached to a machine with Agent for Scale Computing has been reached.
The following error can be found in the mms.log on the Agent for Scale Computing:
| error 0x1350016: TOL: Failed to execute the command. Releasing an attached disk | line: 0x8d165e86fb8195bd | file: d:/1739/enterprise/common/tol/command/command.cpp:495 | function: MakeFailResult | CommandID: 8731B46F-3AED-4F73-9627-6B22764FD563 | $module: disk_bundle_tape_off_glxa64_27009 | | error 0x2d3002f: Failed to make Thrift API call. | line: 0xc92d96870ebf86fe | file: d:/1739/enterprise/virtualization/platforms/scale/client/client.cpp:861 | function: SafeCallWithRetry | $module: scale_plugin_glxa64_27009 | | error 0x2d30012: Failed to delete a block device with UUID 'eb50fda1-535a-43b9-acc9-3d1a3d2cabd2'. | line: 0xc92d96870ebf8856 | file: d:/1739/enterprise/virtualization/platforms/scale/client/client.cpp:1205 | function: operator() | $module: scale_plugin_glxa64_27009 | | error 0x2d30003: TException - service has thrown: EPermissionDenied(permissionDescription=PermissionDescription(functionName=VirDomainBlockDeviceDelete, description=Delete a @see VirDomainBlockDevice)) | line: 0xc92d96870ebf86c7 | file: d:/1739/enterprise/virtualization/platforms/scale/client/client.cpp:806 | function: SafeCall | $module: scale_plugin_glxa64_27009
Cause
Agent for Scale Computing can attach max. 26 snapshots. If the "VM Delete" role is missing for the account that administers the Agent for Scale Computing, the snapshots will be not detached and deleted after each successful backup. When the max. amount of attached snapshots is reached, further VM backups will fail with the above error.
Solution
Add VM Delete role to the Scale Computing HC3 account:
- Open the console of Agent for Scale Computing
- Under "Control center" open "User management"
- Find your custom user in the list and click on "Edit"
- Select the role "VM Delete" and save changes
- Restart the Agent for Scale Computing
- Remove already created snapshots manually: open the Devices tab on VM with Acronis Appliance, find the disk you want to detach, click More, then click Delete and confirm deletion. This will detach the disk only from Appliance (not from the original VM).
- Run new VM backup.