Symptoms
1. Backup storage was registered initially with ACI version 4.5 and below;
2. Attempt to update ABGW certificate via WebCP > Storage Services > Backup Storage > Settings > Certificate or via CLI in ACI 4.6/4.7.0 fails with error like the following:
Cloud installation setup id '1549158355606fa6e94ef55b33886b73-1637911640' does not match the response of account server '7907a68a-af39-45b2-af96-d0971ec7e544'
Where ID in error is equal to setup-id parameter from registration info file, e.g.:
[root@node01 ~]# vstorage-abgw-register update-crt
...
setup id '1549158355606fa6e94ef55b33886b73-1637911640' does not match the response of account server '7907a68a-af39-45b2-af96-d0971ec7e544'
[root@node01 ~]# grep setup-id /mnt/vstorage/vols/acronis-backup/certs/.abgw.abc-registration-info
setup-id = 1549158355606fa6e94ef55b33886b73-1637911640
Cause
Issue in product, legacy format of setup-id in .abgw.abc-registration-info
file cannot be handled by update certificate procedures.
Solution
The issue has been fixed in the new version 5.1, update both ACI and backup agents to the latest version.
If you are unable to update yet, do the following workaround
Workaround
Format of setup-id in registration-info file should be corrected automatically upon 4.6 -> 4.7-latest update, so if issue is faced on 4.6 version - cluster should be updated to the latest available ACI version.
In case if cluster was already updated to build lower than 4.7.0-237, setup-id value should be updated manually, using the approach below:
1. Check IDs from error, e.g.:
setup id '1549158355606fa6e94ef55b33886b73-1637911640' does not match the response of account server '7907a68a-af39-45b2-af96-d0971ec7e544'
2. Update registration-info file with values of new format by issuing the command vstorage-abgw-register update-cfg -U
and verify that values have been changed accordingly:
[root@node01 ~]# vstorage-abgw-register update-cfg -U
...
getting registration UUID by legacy UID
got actual registration UUID: 7907a68a-af39-45b2-af96-d0971ec7e544
tmpCertsDir is '/mnt/vstorage/vols/acronis-backup/tmp.certs312302930'
tmpConfDir is '/mnt/vstorage/vols/acronis-backup/tmp.conf.d271725705'
saving in /mnt/vstorage/vols/acronis-backup/tmp.conf.d271725705/certs.default
configuration successfully stored in /mnt/vstorage/vols/acronis-backup/conf.d/certs.defa
[root@node01 ~]# grep setup-id /mnt/vstorage/vols/acronis-backup/certs/.abgw.abc-registration-info
setup-id = 7907a68a-af39-45b2-af96-d0971ec7e544
setup-id-compat = 1549158355606fa6e94ef55b33886b73-1637911640
3. Verify if certificate update completes without errors:
[root@node01 ~]# vstorage-abgw-register update-crt
...
generating certificates
tmpCertsDir is '/mnt/vstorage/vols/acronis-backup/tmp.certs582091609'
tmpConfDir is '/mnt/vstorage/vols/acronis-backup/tmp.conf.d082103012'
saving in /mnt/vstorage/vols/acronis-backup/tmp.conf.d082103012/certs.default
Contact Acronis support in case if the issue with ABGW certificate update will persist.