Symptoms
C2C agent tries to apply a protection plan to O365 mailboxes, Sharepoint, etc.
Activity fails with:
A backup agent error: 'nothing is processed in protection applying'
Cause 1
The alert could appear if there are new resources but they weren't protected when applying the plan, for example when there are new items discovered in Microsoft 365.
Solution 1
To synchronize the changes between Microsoft 365 and Acronis console follow this article
Cause 2
The resource has a long name; it's not possible to protect the site if it's name exceed the maximum length. The current limitation is 186 characters.
Solution 2
In this case, change the name of resources from Microsoft 365 side.